Bug 483673 - Page Request Error when navigating to Package Details from Package Details
Page Request Error when navigating to Package Details from Package Details
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Jay Dobies
Jeff Browning
: Regression
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-02-02 17:37 EST by Jeff Browning
Modified: 2009-09-10 16:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:32:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Browning 2009-02-02 17:37:17 EST
Description of problem:
When on the Package Details tab, clicking the Details tab again will give a Page Request Error.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Navigate to any package in any channel
2. While on the details page (( Example: https://fjs-0-01.rhndev.redhat.com/rhn/software/packages/Details.do?pid=11452 )) click the Details tab again.
  
Actual results:
The Systems tab on the master nav bar highlights rather than the Channels tab, and the following error is displayed on the screen.

Page Request Error

We could not display the requested page because of a missing parameter. This error could have occured several ways:

   1. An incorrect or out-of-date bookmark.
   2. An incorrect or out-of-date hyperlink.
   3. Your browser encountered an error handling request parameters. Continued use of this browser may yield unexpected results.
   4. You've found an error in our site. Please help us by filling out this form with details of how you received this message.


Expected results:
It should just refresh the page already being displayed. This is what happens for the other tabs that I've tried.

Additional info:
I am not entirely sure if this should also be blocked against NEVRA as well ( 457078 ). While the changes made for NEVRA did make changes to the Package Details display, it did not, as far as I can tell, directly do anything to the link that is busted in this case. They may be related though, at least superficially.
Comment 1 Jay Dobies 2009-03-20 10:13:36 EDT
Commit: 2ca05bb1fd57865747cc2e179e1f0fabc3f63967

Updated navigation link to point to correct destination.
Comment 2 Jeff Browning 2009-04-21 15:14:36 EDT
Verified
Comment 3 Preethi Thomas 2009-08-04 11:26:40 EDT
Release Pending
test1182.test.redhat.com
Comment 4 Brandon Perkins 2009-09-10 16:32:30 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.