Bug 483710 - [RHEL6]: Fix for xen panic on new processors
[RHEL6]: Fix for xen panic on new processors
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
low Severity medium
: beta
: ---
Assigned To: Xen Maintainance List
Martin Jenner
:
Depends On:
Blocks: 442586
  Show dependency treegraph
 
Reported: 2009-02-03 03:29 EST by Jane Lv
Modified: 2009-09-24 13:42 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-09 01:48:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jane Lv 2009-02-03 03:29:01 EST
Description of problem:

When trying to boot a hvm guest on Xen, the xen hypervisor crashes, rebooting
the physical system.

This issue is related to the up coming Intel Boxboro and Westmere systems.

This is the bug fix patch.  The patch is already in the xen-unstable.hg tree.  Here is a link to the patch:
http://xenbits.xensource.com/xen-unstable.hg?rev/f6a455c9f01d

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Chris Lalancette 2009-02-04 04:00:36 EST
Hm, I took a quick look at this patch.  It doesn't apply at all to the RHEL-5 HV, since it has diverged quite a bit from what is in upstream Xen.  What's the problem that this is trying to solve (it's not clear to me from the c/s or from the problem description), and does that problem exist in RHEL-5?

Chris Lalancette
Comment 3 Jane Lv 2009-02-06 03:12:05 EST
(In reply to comment #2)
> Hm, I took a quick look at this patch.  It doesn't apply at all to the RHEL-5
> HV, since it has diverged quite a bit from what is in upstream Xen.  What's the
> problem that this is trying to solve (it's not clear to me from the c/s or from
> the problem description), and does that problem exist in RHEL-5?
> 
> Chris Lalancette

Chris,

I have checked.  This patch is related to oprofile support for HVM guest, which is not in the RHEL5 Xen package.  So the issue won't impact RHEL5.

RHEL6 should include the very up-to-date Xen package.  I will move this bug to RHEL6 for validation purpose.
Comment 4 RHEL Product and Program Management 2009-03-06 06:23:24 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 John Villalovos 2009-03-27 14:31:24 EDT
Jane,

Can we close this bug, since RHEL6 will NOT have Xen in it.
Comment 6 Jane Lv 2009-04-09 01:48:22 EDT
Yes, we can close this bug.

Note You need to log in before you can comment on or make changes to this bug.