Bug 483735 - iwl3945 driver stopped by RF kill switch on boot
iwl3945 driver stopped by RF kill switch on boot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-03 07:58 EST by Andrew John Hughes
Modified: 2009-03-04 11:42 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 11:42:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew John Hughes 2009-02-03 07:58:28 EST
Description of problem:

Wireless fails to initialise on boot.  From the dmesg output, it appears the RF kill switch is being activated immediately:

$ dmesg | grep iwl3945

iwl3945: Detected Intel Wireless WiFi Link 3945ABG
iwl3945: Tunable channels: 13 802.11bg, 23 802.11a channels
iwl3945 0000:03:00.0: PCI INT A disabled
iwl3945 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
iwl3945 0000:03:00.0: restoring config space at offset 0x1 (was 0x100102, writing 0x100106)
iwl3945: Radio disabled by HW RF Kill switch
iwl3945 0000:03:00.0: PCI INT A disabled
iwl3945 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
iwl3945 0000:03:00.0: restoring config space at offset 0x1 (was 0x100102, writing 0x100106)
iwl3945: Radio disabled by HW RF Kill switch
iwl3945 0000:03:00.0: PCI INT A disabled
iwl3945 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
iwl3945 0000:03:00.0: restoring config space at offset 0x1 (was 0x100102, writing 0x100106)
iwl3945: Radio disabled by HW RF Kill switch
iwl3945 0000:03:00.0: PCI INT A disabled
iwl3945 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
iwl3945 0000:03:00.0: restoring config space at offset 0x1 (was 0x100102, writing 0x100106)
iwl3945: Radio disabled by HW RF Kill switch
iwl3945 0000:03:00.0: PCI INT A disabled

This is on a Lenovo X61 laptop provided by Red Hat.  Attempts to initiaise wireless by Fn+F5 appear to do nothing (though I assume they are responsible for the repeated messages above).

The wireless has been working and NetworkManager was prompting to connect to WLANs it found earlier during the F10 lifecycle.  This has only occurred after post-F10 updates.

Version-Release number of selected component (if applicable):

 2.6.27.12-170.2.5.fc10.x86_64

How reproducible:

Boot the machine.  NetworkManager claims wireless is enabled, but the light on the laptop is unlit.

Steps to Reproduce:
1.
2.
3.
  
Actual results:

No wireless :(

Expected results:

Wireless :)

Additional info:
Comment 1 Andreas Utterberg 2009-03-03 13:09:44 EST
I have also after update no wireless, have worked perfectly before. This must have very high priority!! Wireless is broken on all my Fedora 10 systems now.

Breakout from messages:

Mar  3 18:58:40 localhost kernel: firmware: requesting iwlwifi-3945-1.ucode                                                                                                                   
Mar  3 18:58:40 localhost kernel: iwl3945: Radio disabled by HW RF Kill switch 

From messages:

Mar  3 18:57:10 localhost kernel: fuse init (API version 7.9)
Mar  3 18:57:30 localhost kernel: nepomukservices[3130]: segfault at 4 ip 047168a2 sp bfafdc40 error 4 in libQtCore.so.4.4.3[46ce000+21e000]
Mar  3 18:58:30 localhost NetworkManager: <info>  (wlan0): now unmanaged
Mar  3 18:58:30 localhost NetworkManager: <info>  (wlan0): device state change: 2 -> 1
Mar  3 18:58:36 localhost kernel: iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26kds
Mar  3 18:58:36 localhost kernel: iwl3945: Copyright(c) 2003-2008 Intel Corporation
Mar  3 18:58:36 localhost kernel: iwl3945 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
Mar  3 18:58:36 localhost kernel: iwl3945: Detected Intel Wireless WiFi Link 3945ABG
Mar  3 18:58:36 localhost kernel: iwl3945: Tunable channels: 13 802.11bg, 23 802.11a channels
Mar  3 18:58:36 localhost NetworkManager: <info>  wlan0: driver is 'iwl3945'.
Mar  3 18:58:36 localhost NetworkManager: <info>  wlan0: driver supports SSID scans (scan_capa 0x01).
Mar  3 18:58:36 localhost NetworkManager: <info>  Found new 802.11 WiFi device 'wlan0'.
Mar  3 18:58:36 localhost NetworkManager: <info>  (wlan0): exported as /org/freedesktop/Hal/devices/net_00_1c_bf_51_35_24
Mar  3 18:58:40 localhost NetworkManager: <info>  (wlan0): device state change: 1 -> 2
Mar  3 18:58:40 localhost NetworkManager: <info>  (wlan0): bringing up device.
Mar  3 18:58:40 localhost kernel: iwl3945 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
Mar  3 18:58:40 localhost kernel: firmware: requesting iwlwifi-3945-1.ucode
Mar  3 18:58:40 localhost kernel: iwl3945: Radio disabled by HW RF Kill switch
Mar  3 18:58:40 localhost NetworkManager: <WARN>  nm_device_hw_bring_up(): (wlan0): device not up after timeout!
Mar  3 18:58:40 localhost NetworkManager: <info>  (wlan0): deactivating device (reason: 2).
Comment 2 John W. Linville 2009-03-03 13:51:38 EST
What kernel version worked?  What was the first version to fail?

Are you absolutely sure that the RF kill switch is disabled (i.e. set to enable the radio)?  Note, I'm not talking about Fn-F5 -- on my t61 and this t400 there are mechanical slide switches on the front edge of the laptop.  Your machine may have something similar.
Comment 3 Andreas Utterberg 2009-03-03 15:04:14 EST
I dont know what last kernel was that worked, i updated my computers and after the update  wireless was broken.

[root@thundera packages]# rpm -qa | grep kernel
kerneloops-0.12-1.fc10.i386
kernel-2.6.27.19-170.2.35.fc10.i686
kernel-2.6.27.12-170.2.5.fc10.i686
kernel-2.6.27.15-170.2.24.fc10.i686
kernel-firmware-2.6.27.19-170.2.35.fc10.noarch

[root@thundera packages]# uname -r
2.6.27.19-170.2.35.fc10.i686

I have no physical kill switch, im running F10 on two Dell Latitude D830 laptops, so the kill switch message makes no sense. Let me know if i can provide more input for fast resolving since this issue is most troubleing.
Comment 4 John W. Linville 2009-03-03 15:21:39 EST
I see...and what happens when you manipulate the soft rfkill switch that must be somewhere on that box?  Also, please ensure that there is no BIOS setting disabling the wireless lan device.
Comment 5 Andreas Utterberg 2009-03-03 15:37:51 EST
Im sorry, i must be really tired....it works fine for me. I had manually disabled the wifi card and was stupid enough to didnt double check this before reporting!

Im sorry again!
Comment 6 John W. Linville 2009-03-03 16:06:24 EST
Hey, it happens... :-)

Andrew, are you still experiencing a problem?
Comment 7 Andrew John Hughes 2009-03-04 11:42:03 EST
I was, then I read this report this morning and found the mechanical slide switch you mention.  I've not seen it before and it looks like due to the dumb positioning of the switch, it's been knocked into a semi-on/off position that disabled RF.  Flicking it turned Bluetooth back on.  Wifi needed a reboot but it seems to be back now.

Thanks for the solution.  This bug can now be closed.

Note You need to log in before you can comment on or make changes to this bug.