Bug 483750 - Refactor java binding URL to allow queue/exchange and binding options
Refactor java binding URL to allow queue/exchange and binding options
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-java (Show other bugs)
1.1
All Linux
high Severity medium
: 1.3
: ---
Assigned To: Rajith Attapattu
Frantisek Reznicek
:
: 484266 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-03 09:14 EST by Rajith Attapattu
Modified: 2015-11-15 19:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-27 16:04:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rajith Attapattu 2009-02-03 09:14:55 EST
Currently the java client can not do the following when declaring queues.

1. Specify exchange declare options
2. Specify queue declare options
3. Specify binding options
4. Bind a queue to an exchange routingkey pair
Comment 1 Rajith Attapattu 2010-02-17 22:55:22 EST
Support for this is added via the new addressing syntax
It's available from rev 906145 and upwards in Qpid trunk.
Comment 2 Frantisek Reznicek 2011-01-25 07:40:14 EST
The feature has been implemented, tested on RHEL 4.8 / 5.6 on packages:
qpid-java-*0.7.946106-14.el5


-> VERIFIED
Comment 3 Justin Ross 2011-06-27 16:04:00 EDT
Fixed and verified; closing.
Comment 4 Justin Ross 2011-06-27 16:06:26 EDT
*** Bug 484266 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.