Bug 483791 - ISE while confirming package upgrade
ISE while confirming package upgrade
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Sayli Karmarkar
: Regression
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-02-03 11:43 EST by Sayli Karmarkar
Modified: 2015-03-22 21:09 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:32:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sayli Karmarkar 2009-02-03 11:43:24 EST
Description of problem:
ISE on while confirming package upgrade

Satellite-5.3.0-RHEL5-re20081223.1

Steps to Reproduce:
1. Register a system
2. Go to rhn/systems/details/packages/UpgradableList.do and schedule a package
upgrade.
3. Confirm it on the next page

  
Actual results:
Internal server error at step 3.


Expected results:
No Error
Comment 1 Sayli Karmarkar 2009-02-03 11:44:34 EST
Additional info:

Here is the useful part of web traceback:

Request:
Local Name = rlx-0-22.rhndev.redhat.com
Server Name = rlx-0-22.rhndev.redhat.com
Requested Session Id came from Cookie
Requested Session Valid = true
Session = org.apache.catalina.session.StandardSessionFacade@72ba72ba[session=StandardSession[924AE2271BF1A76E4D89D1726DE4FC42]]
Protocol = https
Request Locale = en_US
Request Character Encoding = UTF-8
Attribute Names = rhnActiveLang, datePickerForm, javax.servlet.jsp.jstl.fmt.timeZone.request, javax.servlet.request.key_size, __sitemesh__filterapplied, javax.servlet.request.ssl_session, javax.servlet.request.cipher_suite, org.apache.struts.action.MESSAGE, session, org.apache.struts.action.mapping.instance, requestedUri, system, org.apache.struts.action.MODULE, 

Form Variables:
  date_year: 2009
  sid: 1000010082
  list_4021519721_filterby: Package Name
  list_4021519721_oldfilterval: 
  date_am_pm: 0
  list_4021519721_filterval: 
  use_date: false
  date_day: 3
  4021519721_PAGE_SIZE_LABEL_SELECTED: null
  4021519721_PAGE_SIZE_LABEL: 100
  date_minute: 58
  dispatch: Confirm
  date_hour: 10
  date_month: 1


User Information:
User admin (id 1, org_id 1)
Exception:
javax.servlet.ServletException: Could not set null value for parameter: arch_id
	at org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:535)


...

Caused by: com.redhat.rhn.common.db.datasource.ParameterValueNotFoundException: Could not set null value for parameter: arch_id
	at com.redhat.rhn.common.db.datasource.CachedStatement.setupParamMap(CachedStatement.java:414)
	at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:448)
	at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:425)
	at com.redhat.rhn.common.db.datasource.CachedStatement.executeUpdate(CachedStatement.java:269)
	at com.redhat.rhn.common.db.datasource.WriteMode.executeUpdate(WriteMode.java:32)
	at com.redhat.rhn.manager.action.ActionManager.schedulePackageAction(ActionManager.java:1464)
	at com.redhat.rhn.manager.action.ActionManager.schedulePackageInstall(ActionManager.java:1069)
	at com.redhat.rhn.manager.action.ActionManager.schedulePackageUpgrade(ActionManager.java:1055)
	at com.redhat.rhn.frontend.action.rhnpackage.UpgradeConfirmSetupAction.schedulePackageAction(UpgradeConfirmSetupAction.java:59)
	at com.redhat.rhn.frontend.action.rhnpackage.BaseSystemPackagesConfirmAction.executePackageAction(BaseSystemPackagesConfirmAction.java:171)
	at com.redhat.rhn.frontend.action.rhnpackage.BaseSystemPackagesConfirmAction.execute(BaseSystemPackagesConfirmAction.java:72)
	at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
	... 40 more





~SayliK
Comment 2 Justin Sherrill 2009-02-13 15:40:40 EST
Works for me in latest build.
Comment 3 Sayli Karmarkar 2009-02-13 15:42:44 EST
Verified on the latest build.
Comment 4 Miroslav Suchý 2009-08-05 04:15:29 EDT
verified in stage
Comment 5 Brandon Perkins 2009-09-10 16:32:36 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.