Bug 483836 - Tcl 8.5.3 threading
Tcl 8.5.3 threading
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: tcl (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-03 15:37 EST by Vasileios Anagnostopoulos
Modified: 2009-02-17 06:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 02:04:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vasileios Anagnostopoulos 2009-02-03 15:37:51 EST
Description of problem:

tcl-8.5.3-1.fc10.i386 is not multithreaded

Version-Release number of selected component (if applicable):

tcl-8.5.3-1.fc10.i386

How reproducible:

Always

Steps to Reproduce:
1. Download tloona 1.3.2 from sourceforge
2. Install thread extension
3. Untar tloona and in the folder run wis8.8 main.tcl
  
Actual results:

 wish8.5 main.tcl
Error in startup script: Tcl core wasn't compiled for threading.
    while executing
"load [file join $dir libthread2.6.5.so]"
    (procedure "thread_load" line 2)
    invoked from within
"thread_load /usr/lib/tcl8.5/thread2.6.5"
    ("package ifneeded Thread 2.6.5" script)
    invoked from within
"package require Thread 2.6.3"
    (file "main.tcl" line 12)


Expected results:

The program runs

Additional info:

No problems with activetcl 8.5.5
Comment 1 Marcela Mašláňová 2009-02-04 02:04:33 EST
Hello,
I'm aware of this problem. I can't compile tcl with thread support because than other programmes, which are included in Fedora repo, don't run. You can rebuild it with thread support easily if you remove from specfile --disable-threads.

I was looking more on this issue and there's no simple solution. Is it recommended for distros to built it without.

btw this is not activetcl.
Comment 2 Vasileios Anagnostopoulos 2009-02-12 13:51:05 EST
Hi again. A sentence caught my attention

"I can't compile tcl with thread support because than
other programmes, which are included in Fedora repo, don't run"

Which other programs? I may be able to fix them. It is a shame it works ok on my OpenSolaris 2008.11 (I use the active tcl there too besides there own)

"btw this is not activetcl."

I know but I had no other option to run tloona.

At work (win-xp-32bit, bliahhhh!!!!) I use wintcltk which is thread enabled. Still no problems.

I fedora <=5 I didn't install it, I compiled from source everything I wanted with success. So maybe, I say maybe, I can help.

"Is it recommended for distros to built it without."

I do not agree because it is not experimental.
Comment 3 Marcela Mašláňová 2009-02-13 02:23:55 EST
(In reply to comment #2)
> Hi again. A sentence caught my attention
> 
> "I can't compile tcl with thread support because than
> other programmes, which are included in Fedora repo, don't run"
> 
> Which other programs? I may be able to fix them. It is a shame it works ok on
> my OpenSolaris 2008.11 (I use the active tcl there too besides there own)
> 
I'm aware of only this broken programme bugzilla#443246 but here's probably  more of them.
> "btw this is not activetcl."
> 
> I know but I had no other option to run tloona.
> 
> At work (win-xp-32bit, bliahhhh!!!!) I use wintcltk which is thread enabled.
> Still no problems.
> 
;-)
> I fedora <=5 I didn't install it, I compiled from source everything I wanted
> with success. So maybe, I say maybe, I can help.
> 
In the earliest version was tcl8.4 which worked fine with threads. 
> "Is it recommended for distros to built it without."
> 
> I do not agree because it is not experimental.

The change of tcl to run without threads was done in F-9 after reading this:
http://groups.google.com/group/comp.lang.tcl/browse_thread/thread/7bc3d1e0c33ba357/ce6a1324bada8db0?pli=1
As I understand there's problematic implementation of threading.
Comment 4 Vasileios Anagnostopoulos 2009-02-13 09:25:32 EST
Hi again, sorry for asking to many questions and I am not expecting an answer. But if you have time : In case I want to implement an NPTL threading for TCL where can I find more information? I yahoo-ed but couldn't find something informative only design consideration and some older spec document by RedHat but it provides no sample code or how to use special compilation flags. I will try to uninstall all tcl related stuff, recompile with threads enabled and use eggdrop. This is how I will start  tackling it. But I need some info on NPTL usage. Of course there is always an option of GNU-Pthr but they are green and possibly other tcl extensions will break.
Comment 5 Vasileios Anagnostopoulos 2009-02-13 10:02:02 EST
And another comment. It seems to be a pthread_atfork issue. I have to do my tests and talk with tcl devs. Macosx has an implementation based on this but the unix one has nothing.
Comment 6 Marcela Mašláňová 2009-02-17 06:09:11 EST
I'm not experienced user of NPTL so I don't have any advice about it. IMHO this should be really discussed with upstream because they create threads as they are.

Note You need to log in before you can comment on or make changes to this bug.