Bug 483861 - PCI Express card hotplug doesn't work
PCI Express card hotplug doesn't work
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: John Feeney
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-03 18:15 EST by Robert Story
Modified: 2013-01-10 02:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 02:48:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg from boot, and after modprobe pciehp (44.00 KB, text/plain)
2009-02-03 18:15 EST, Robert Story
no flags Details
lspci -v (14.54 KB, text/plain)
2009-02-03 18:16 EST, Robert Story
no flags Details
some syslog output from my F8 system, where the card/pciehp worked (1.88 KB, text/plain)
2009-02-03 18:45 EST, Robert Story
no flags Details
patch to change link order of the PCIE hotplug driver (1.94 KB, text/plain)
2009-02-05 18:07 EST, Chuck Ebbert
no flags Details

  None (edit)
Description Robert Story 2009-02-03 18:15:59 EST
Created attachment 330794 [details]
dmesg from boot, and after modprobe pciehp

Description of problem:
When I insert an ExpressCard compact flash adapter into my laptop, the card is not recognized.

Version-Release number of selected component (if applicable):
2.6.27.9-159.fc10.i686

How reproducible:
always

Steps to Reproduce:
1.boot
2.insert card
3.
  
Actual results:
nothing

Expected results:
card recognized and assigned to /dev/sd?

Additional info:
In F8, this card was found and all was well after 'modprobe pciehp'. With F10, the modprobe logs "pciehp: slot already registered by another hotplug driver"
Comment 1 Robert Story 2009-02-03 18:16:38 EST
Created attachment 330795 [details]
lspci -v
Comment 2 Robert Story 2009-02-03 18:45:06 EST
Created attachment 330801 [details]
some syslog output from my F8 system, where the card/pciehp worked

some syslog output from my F8 system, where the card/pciehp worked
Comment 3 Chuck Ebbert 2009-02-03 21:59:43 EST
This might be fixed by the recent update in 2.6.29 that changes the link order of the hotplug drivers.
Comment 4 Matthew Garrett 2009-02-04 00:51:13 EST
Chuck:

We should change the config so that pciehp and acpiphp are both statically linked in. That should fix this.
Comment 5 Robert Story 2009-02-04 10:55:40 EST
let me know what I can do to help.. I'm a developer and comfortable with patches and building rpms...
Comment 6 Chuck Ebbert 2009-02-05 18:07:41 EST
Created attachment 331064 [details]
patch to change link order of the PCIE hotplug driver

I changed rawhide to always build in the PCIE hotplug drivers. I think in order to get this working on 2.6.27 we'd need to do that (by removing "CONFIG_HOTPLUG_PCIE=m" from config-x86-generic and config-x86_64-generic) plus we'd need to apply the patch from 2.6.29 that links PCIE hotplug before ACPI hotplug (patch attached.)
Comment 7 Robert Story 2009-02-05 23:13:47 EST
I rebuilt 2.6.27.12-170.2.5.fc10.i686 with this patch, and it works!

Thank you!  If this could be pushed into a f10 update, that would be fantastic.
Comment 8 Robert Story 2009-09-05 11:54:40 EDT
so I've been rebuilding my kernel for each update released for 7 months now. Any chance of getting this into a F10 update? is it in F11? Rawhide?
Comment 9 Bug Zapper 2009-11-18 05:58:59 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2009-12-18 02:48:26 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.