This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 483864 - System restart causes loud popping noise.
System restart causes loud popping noise.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
10
i686 Linux
low Severity low
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-03 19:19 EST by John
Modified: 2009-02-04 19:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 19:48:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John 2009-02-03 19:19:45 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121622 Fedora/3.0.5-1.fc10 Firefox/3.0.5

When restarting the computer, there is an extremely loud popping noise (Capacitor discharging), enough that I leave the room if I select restart on accident to avoid it. The volume has no effect on the level of the pop. Starting up and shutting down windows XP and Fedora both give a soft pop. Windows restart gives soft pop, so the problem is in Linux. Sound card is Sound Blaster Audigy 2 connected to a powered sound system with subwoofer.

Reproducible: Always

Steps to Reproduce:
1. Select restart from the shutdown menu.
2. Allow computer to reboot.
Actual Results:  
Very loud pop emitted from speakers.

Expected Results:  
Quieter pop, similar to when shutting down.

Used to have loud pop when shutting down in Fedora Core 6, but that was fixed sometime during that release. The loud pop on reboot has existed in all versions of Fedora since Fedora Core 6. There are three workarounds I know of:

1. Use shutdown and manually power cycle computer. Undesirable since it hits the computer with a power cycle and causes my fans to spin up unless I let the system cool for a minute.

2. Climb under desk and turn off speaker system (Power switch on powered subwoofer. Unable to relocate). Undesirable.

3. -Open gnome sound mixer.
   -Uncheck Audigy Analog/Digital Output Jack option.
   -Restart system (No pop).
   -Log in.
   -Open gnome sound mixer.
   -Check Audigy Analog/Digital Output Jack option to restore audio.

My smolt profile can be seen here: http://www.smolts.org/client/show/?uuid=pub_1fb55c4d-ae7e-4fac-b455-1e460f50ced5
Comment 1 Jaroslav Kysela 2009-02-04 08:18:36 EST
You may add a line 'amixer set "Audigy Analog/Digital Output" off' to /etc/init.d/halt script bellow Save mixer settings block.
Comment 2 John 2009-02-04 19:48:20 EST
That line failed in my case with the error message

amixer: Unable to find simple control 'Audigy Analog/Digital Output',0

I mucked around with amixer for an hour and finally figured out that I needed to specify my card number in the command. The relevant section of my halt file now looks like

# Save mixer settings, here for lack of a better place.
if [ -s /etc/alsa/alsactl.conf -a -x /sbin/alsactl ]; then
  action $"Saving mixer settings" /sbin/alsactl -E ALSA_CONFIG_PATH=/etc/alsa/alsactl.conf --ignore store
fi
#Turn off speaker output to avoid nasty pop.
amixer -c 0 set 'Audigy Analog/Digital Output Jack' off

Work's perfectly, my problem is fixed. Thank you.

Note You need to log in before you can comment on or make changes to this bug.