Bug 483877 - amarok 2 from fedora repo crashing
amarok 2 from fedora repo crashing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-03 23:28 EST by Deb Mukherjee
Modified: 2009-02-04 22:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 07:30:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of $ldd -d /usr/bin/amarok (5.73 KB, text/plain)
2009-02-03 23:28 EST, Deb Mukherjee
no flags Details
output of $yum deplist amarok (49.99 KB, text/plain)
2009-02-03 23:31 EST, Deb Mukherjee
no flags Details
actual result (45.76 KB, image/png)
2009-02-03 23:33 EST, Deb Mukherjee
no flags Details

  None (edit)
Description Deb Mukherjee 2009-02-03 23:28:00 EST
Created attachment 330810 [details]
output of $ldd -d /usr/bin/amarok

Description of problem:
downloaded amarok2 from the repo issuing "yum install amarok"- no problem there. deleted old ~/.kde/share/apps/amarok and ~/.kde/share/config/amarok*. and issued $amarok. Received a crash. 
output
----$amarok
virtual bool Phonon::Gstreamer::AudioOutput::setOutputDevice(const Phonon::AudioOutputDevice&) "default" 
Object::connect: No such slot MainWindow::showStatistics()
Object::connect:  (receiver name: 'MainWindow')
/usr/bin/kbuildsycoca4: symbol lookup error: /usr/lib64/libkdeinit4_kbuildsycoca4.so: undefined symbol: _ZN16KMimeTypeFactory12virtual_hookEiPv

Version-Release number of selected component (if applicable):
Qt: 4.4.3
KDE: 4.1.80 (KDE 4.1.80 (KDE 4.2 Beta1))
Amarok: 2.0.1


How reproducible:
Start amarok. 


Steps to Reproduce:
1.
2.
3.
  
Actual results:
see attached file 2.


Expected results:
amarok starts. without crash.

Additional info: as it can be dependancy issue i have attached the output of $ldd -d /usr/bin/amarok.
Further I should mention I sucessfully compiled amarok2 in this machine. and cleanly uninstalled it before fetching it from the repo.
Comment 1 Deb Mukherjee 2009-02-03 23:31:21 EST
Created attachment 330811 [details]
output of $yum deplist amarok
Comment 2 Deb Mukherjee 2009-02-03 23:33:17 EST
Created attachment 330812 [details]
actual result
Comment 3 Rex Dieter 2009-02-04 07:30:30 EST
> KDE: 4.1.80

^^^^^^^^

Not supported.  kde-4.1.4 is in stable updates, with kde-4.2.0 coming soon.
Comment 4 Deb Mukherjee 2009-02-04 19:47:31 EST
I do not understand this 
I do have KDE 4.1.4 and not 4.1.8 as can be seen below. 
Why amarok is returning KDE 4.1.8?
----
[xxx 19:42:30 ~] $ yum info kdebase
Loaded plugins: fastestmirror, refresh-packagekit
Installed Packages
Name       : kdebase
Arch       : x86_64
Epoch      : 6
Version    : 4.1.4
Release    : 2.fc10
Size       : 13 M
Repo       : installed
Summary    : K Desktop Environment 4 - Core Files
URL        : http://www.kde.org/
License    : GPLv2
Description: Core runtime requirements and applications for the K Desktop
           : Environment 4.

[xxx 19:42:56 ~] $ amarok -v
Qt: 4.4.3
KDE: 4.1.80 (KDE 4.1.80 (KDE 4.2 Beta1))
Amarok: 2.0.1
----
Comment 5 Rex Dieter 2009-02-04 20:54:10 EST
For me (using kde-4.2.0 pkgs queue'd for updates-testing):
$ kde4-config -v
Qt: 4.4.3
KDE: 4.2.00 (KDE 4.2.0)
kde4-config: 1.0

$ amarok -v
Qt: 4.4.3
KDE: 4.2.00 (KDE 4.2.0)
Amarok: 2.0.1
Comment 6 Deb Mukherjee 2009-02-04 21:22:19 EST
mine looks like this;

$ kde4-config -v 
Qt: 4.4.3
KDE: 4.1.80 (KDE 4.1.80 (KDE 4.2 Beta1))
kde4-config: 1.0
Comment 7 Rex Dieter 2009-02-04 21:49:41 EST
you've got something strange/wrong alrighty.  Sure you don't have a self-compiled kde4 (or other) on this box?
Comment 8 Deb Mukherjee 2009-02-04 22:06:27 EST
"yum install kdelibs --enablerepo=kde-testing" 
solved the problem and amarok2 is up and running.

Note You need to log in before you can comment on or make changes to this bug.