Bug 484021 - tanukiwrapper requirements on s390x
tanukiwrapper requirements on s390x
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
s390x Linux
high Severity high
: ---
: ---
Assigned To: Dennis Gilmore
Jan Hutař
:
Depends On:
Blocks: 456985 486216
  Show dependency treegraph
 
Reported: 2009-02-04 07:45 EST by Jan Hutař
Modified: 2009-09-10 14:14 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:14:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhn-installation.log (64.20 KB, application/octet-stream)
2009-02-04 07:45 EST, Jan Hutař
no flags Details

  None (edit)
Description Jan Hutař 2009-02-04 07:45:08 EST
Created attachment 330859 [details]
rhn-installation.log

Description of problem:
Installation fails on s390x


Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090203.0
Red Hat Enterprise Linux Server release 5.3 (Tikanga)


How reproducible:
tried once


Steps to Reproduce:
1. /mnt/redhat/devel/candidate-trees/Satellite-5.3.0-RHEL5-re20090203.0/s390x/s390x/install.pl --answer-file=answers.txt --non-interactive --disconnected --run-updater


Actual results:
* Starting the Red Hat Network Satellite installer.
* Loading answer file: answers.txt.
* Performing pre-install checks.
* Pre-install checks complete.  Beginning installation.
* RHN Registration.
** Registration: Disconnected mode.  Not registering with RHN.
* Checking for uninstalled prerequisites.
There are some packages from Red Hat Enterprise Linux that are not part
of the @base group that Satellite will require to be installed on this
system. The installer will try resolve the dependencies automatically.
* Applying updates.
* Installing RHN packages.
Could not install RHN packages.  Most likely your system is not configured with the @Base package group.  See the RHN Satellite Server Installation Guide for more information about Software Requirements.  Exit value: 1.
Please examine /var/log/rhn/rhn-installation.log for more information.


Expected results:
Installation should continue.
Comment 3 Dennis Gilmore 2009-02-19 20:59:35 EST
https://brewweb.devel.redhat.com/buildinfo?buildID=81791
https://brewweb.devel.redhat.com/buildinfo?buildID=81792

tanukiwrapper  is inherited from EAP since they dont build for s390 or s390x  we needed to rebuild.  some of the gcc flags used are not valid with gccc as shipped in RHEL4  I have fixed the package to build  and it is checked in and built from CVS
Comment 4 Dennis Gilmore 2009-02-23 15:00:06 EST
compose from feb 20th has 3.2.1 builds of tanikiwrapper on all arches
Comment 5 Jan Hutař 2009-02-24 03:20:36 EST
For now I'm getting these webqa errors - I'll verify asap:

Error Downloading Packages:
  1:perl-TimeDate-1.16-5.el5.noarch: failed to retrieve getPackage/perl-TimeDate-1.16-5.el5.noarch.rpm from rhel-s390x-server-fastrack-5
error was [Errno 14] HTTP Error 404: Not Found
  9:mkisofs-2.01-10.7.el5.s390x: failed to retrieve getPackage/mkisofs-2.01-10.7.el5.s390x.rpm from rhel-s390x-server-fastrack-5
error was [Errno 14] HTTP Error 404: Not Found
  perl-DBI-1.52-2.el5.s390x: failed to retrieve getPackage/perl-DBI-1.52-2.el5.s390x.rpm from rhel-s390x-server-fastrack-5
error was [Errno 14] HTTP Error 404: Not Found

http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=47640

Thanks,
Jan
Comment 6 Jan Hutař 2009-02-24 16:41:08 EST
There are still these errors in webqa, but I see tanukiwrapper is on the installation CD in the log rhn-installation.log:

Examining Satellite/tanukiwrapper-3.2.1-5.el5sat.s390x.rpm: tanukiwrapper-3.2.1-5.el5sat.s390x
Marking Satellite/tanukiwrapper-3.2.1-5.el5sat.s390x.rpm to be installed
Comment 7 Jan Hutař 2009-02-24 16:42:01 EST
Forgot to mention that used Satellite-5.3.0-RHEL5-re20090220.1 embedded DB.
Comment 8 Milan Zázrivec 2009-09-08 08:03:18 EDT
No unresolved dependencies on final isos, tanukiwrapper is present
in version tanukiwrapper-3.2.1-9. RELEASE_PENDING
Comment 9 Brandon Perkins 2009-09-10 14:14:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.