Bug 484104 - [LTC 5.4 FEAT] EDAC Support for IBM x3850/x3950/x3850 M2/x3950 M2
[LTC 5.4 FEAT] EDAC Support for IBM x3850/x3950/x3850 M2/x3950 M2
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.4
All All
high Severity high
: rc
: 5.4
Assigned To: Mauro Carvalho Chehab
Red Hat Kernel QE team
: FutureFeature
Depends On: 482874
Blocks: 445204
  Show dependency treegraph
 
Reported: 2009-02-04 14:40 EST by IBM Bug Proxy
Modified: 2013-07-04 18:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-11 09:30:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 51452 None None None Never

  None (edit)
Description IBM Bug Proxy 2009-02-04 14:40:20 EST
=Comment: #0=================================================
Emily J. Ratliff <ratliff@austin.ibm.com> - 
1. Feature Overview:
Feature Id:	[201264]
a. Name of Feature:	EDAC Support
b. Feature Description
RAS Enhancements    Require EDAC support for all chipsets in IBM systems (including proprietary).  
 Also would prefer the ability to disable EDAC drivers during install for platforms that don't
require them.    The majority of IBM Intel and AMD based servers do memory and CPU predictive
failure analysis (PFA) in the BIOS with the help of the BMC. When EDAC drivers are loaded they will
poll for memory errors once a second. The EDAC drivers may read the same hardware status registers 
that the BIOS is using for PFA. This can easily lead to interference between EDAC and the BIOS if
EDAC reads and clears the registers before the BIOS gets a chance to do so and can potentially  
render the BIOS's PFA mechanism dysfunctional. Therefore, a mechanism (black/white listing or
perhaps something more robust) for disabling EDAC on platforms that already do PFA in firmware would
be ideal.

2. Feature Details:
Sponsor:	xSeries
Architectures:
x86
x86_64

Arch Specificity: Both
Affects Installer: Yes
Affects Kernel Modules: Yes
Delivery Mechanism: Request Red Hat development assistance
Category:	Kernel
Request Type:	Kernel - Enhancement from Upstream
d. Upstream Acceptance:	In Progress
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	The EDAC code for some IBM chipsets has been started. The target at
this point is probably 2.6.27.   Additionally, there are components to this feature request that
require code from the distros (ability to disable/enable EDAC based on the platform type).

3. Business Case
Need to provide a mechanism for customers to be able to detect and report platform errors from Linux.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Monte Knutson, mknutson@us.ibm.com, 877-894-1495

Technical contact(s):
Kevin Stansell, kstansel@us.ibm.com
Chris McDermott, mcdermoc@us.ibm.com

IBM Manager:
Deneen T. Dock, deneen@us.ibm.com
Comment 1 RHEL Product and Program Management 2009-02-16 10:44:00 EST
Updating PM score.
Comment 2 Mauro Carvalho Chehab 2009-02-25 13:51:00 EST
Could you please define better what chipsets are you referring? We should coordinate the EDAC efforts with others already started. for example, the bug #482874 is about the support for IBM x3850/3950. 

There are other EDAC feature request bz#s also opened.
Comment 3 IBM Bug Proxy 2009-03-09 17:20:53 EDT
(In reply to comment #5)
> Could you please define better what chipsets are you referring? We should
> coordinate the EDAC efforts with others already started. for example, the bug
> #482874 is about the support for IBM x3850/3950.
>
> There are other EDAC feature request bz#s also opened.
>

I apologize for the delay. Didn't see your question in my inbox until just now. The chipsets we are referring to are those included in the x3850/x3950/x3850 M2/x3950 M2. This is the EXA4 chipset, a memory/scalability controller for these High End servers. Currently, there is no EDAC driver upstream for this chipset, however one is under development.
Comment 4 John Jarvis 2009-06-11 09:30:01 EDT
Closing as WONTFIX for RHEL 5.4 due to lack of capacity, please feel free to
Comment 5 IBM Bug Proxy 2011-02-21 05:21:19 EST
------- Comment From prem.karat@linux.vnet.ibm.com 2011-02-21 05:16 EDT-------
***Closing as part of clean up activity*******

Redhat as closed this bug as WONT FIX.

Cheers,
Prem

Note You need to log in before you can comment on or make changes to this bug.