Bug 484119 - Add serial console options when installing kernel-xen
Add serial console options when installing kernel-xen
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.4
All Linux
high Severity high
: rc
: 5.6
Assigned To: Brian Lane
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-04 16:25 EST by Scott Dodson
Modified: 2011-02-18 18:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-18 18:15:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Dodson 2009-02-04 16:25:57 EST
Description of problem:
If I've configured my system for serial console by adding "console=tty0 console=ttyS0,9600" to the kernel arguments it'd be nice if the necessary options, "com1=9600n8" in this case, were added to the xen kernel line when I install kernel-xen. It currently copies over the options to the vmlinuz module line but the options for xen are necessary as well.

I may be overlooking a better way to do, not sure.

Version-Release number of selected component (if applicable):
5.3

How reproducible:
100% 

Steps to Reproduce:
1. Install RHEL 5.3.
2. Configure the system for serial console access by adding "console=tty0 console=ttyS0,9600n8" to the kernel line, updating inittab, securetty, etc.
3. Install kernel-xen
4. Reboot into the xen kernel
  
Actual results:
Kernel options are copied to the vmlinuz module line, however the xen kernel does not get the necessary options.

title Red Hat Enterprise Linux Server (2.6.18-128.el5xen)
        root (hd0,0)
        kernel /xen.gz-2.6.18-128.el5
        module /vmlinuz-2.6.18-128.el5xen ro root=/dev/myvg/rootvol console=tty0 console=ttyS0,9600n8
        module /initrd-2.6.18-128.el5xen.img



Expected results:
Add com1=9600n8 to the xen kernel line too, ie:

title Red Hat Enterprise Linux Server (2.6.18-128.el5xen)
        root (hd0,0)
        kernel /xen.gz-2.6.18-128.el5 com1=9600n8
        module /vmlinuz-2.6.18-128.el5xen ro root=/dev/myvg/rootvol console=tty0 console=ttyS0,9600n8
        module /initrd-2.6.18-128.el5xen.img


Additional info:
Filed against mkinitrd since that seems to be where the magic happens via new-kernel-pkg
Comment 7 RHEL Product and Program Management 2011-02-18 18:15:06 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.