Bug 484142 - imsettings-applet warnings on Emacs startup in Gnome
imsettings-applet warnings on Emacs startup in Gnome
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: imsettings (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-04 18:25 EST by Christopher Beland
Modified: 2009-04-28 12:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-28 12:09:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Excerpt from .xession-errors when starting Emacs (17.14 KB, text/plain)
2009-02-04 18:25 EST, Christopher Beland
no flags Details

  None (edit)
Description Christopher Beland 2009-02-04 18:25:14 EST
Created attachment 330937 [details]
Excerpt from .xession-errors when starting Emacs

When starting Emacs from the Gnome menu, I got a ton of warnings in
.xsession-errors, including things like:

(imsettings-applet:2862): libimsettings-xim-WARNING **: Invalid entry [no symbol]: <U17ff> :   "ាំ"
(imsettings-applet:2862): GLib-GObject-CRITICAL **: g_boxed_copy: assertion `src_boxed != NULL' failed
(imsettings-applet:2862): GLib-GObject-CRITICAL **: g_boxed_free: assertion `boxed != NULL' failed

I wouldn't want to see any warnings if everything is working properly.  A complete log excerpt is attached.

This is with:

imsettings-0.105.1-2.fc10.x86_64
emacs-22.3-3.fc11.x86_64
Comment 1 Akira TAGOH 2009-02-04 21:08:02 EST
Thank you for your report. it was actually for debugging purpose. I can just disable that warning since it's likely to appear when current keyboard layout doesn't support a symbol. however the above two critical messages basically means a bug. so I'll have a look into it.
Comment 2 Akira TAGOH 2009-02-24 21:06:11 EST
should be fixed in imsettings-0.106.0-1.fc11.
Comment 3 Christopher Beland 2009-03-10 13:28:38 EDT
Thanks for the fix; it has taken care of the original messages.  Unfortunately, I'm now getting a slightly different set of warnings with imsettings-0.106.0-1.fc11.x86_64 and emacs-22.3-8.fc11.x86_64:

(imsettings-applet:11370): libimsettings-xim-WARNING **: Invalid symbol for result: combining_acute

(imsettings-applet:11370): libimsettings-xim-WARNING **: Invalid symbol for result: combining_belowdot

(imsettings-applet:11370): libimsettings-xim-WARNING **: Invalid symbol: dead_belowcomma

(imsettings-applet:11370): libimsettings-xim-WARNING **: Invalid symbol: dead_currency

(imsettings-applet:11370): libimsettings-xim-WARNING **: Invalid symbol for result: combining_grave

(imsettings-applet:11370): libimsettings-xim-WARNING **: Invalid symbol for result: combining_tilde

[These are each repeated several times; duplicates omitted.]
Comment 4 Akira TAGOH 2009-03-10 22:01:16 EDT
Which the keyboard layout are you using?
Those warnings usually means your keyboard layout doesn't support those symbols. if they aren't supposed to be used in your layout, that could be ignored.
It was output to catch up a parser bug though, it may be time to disable it.
Comment 5 Christopher Beland 2009-03-11 08:14:59 EDT
GNOME Keyboard Preferences says "USA".  I don't have any accents or anything like that on my keyboard, and I'm not sure what dead_currency and dead_belowcomma are supposed to look like.
Comment 6 Akira TAGOH 2009-03-11 09:09:27 EDT
Thanks. fair enough. so it would be a time to turn off a message then :)
I'll get rid of them in next push.
Comment 7 Akira TAGOH 2009-03-18 21:22:24 EDT
Fixed in 0.106.1-2.fc11.
Comment 8 Christopher Beland 2009-04-28 12:09:32 EDT
Tested with imsettings-0.106.2-2.fc11.x86_64 and confirmed fixed.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.