Bug 484179 - Internal mike is not working
Internal mike is not working
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-05 03:59 EST by antonio montagnani
Modified: 2009-03-13 13:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-13 13:20:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description antonio montagnani 2009-02-05 03:59:03 EST
Description of problem:
When I switch to the internal mike (that is working on MWindows) no sound can be heard or recorded

Version-Release number of selected component (if applicable):
pulseaudio-0.9.14-1.fc10.i386

How reproducible:
always

Steps to Reproduce:
1.start gnome-sound-recorder
2.record a sound 
3.play it back (only silence)
  
Actual results:
No sound is heard on playback (even in Skype)

Expected results:
It should work, as for sometime worked (and also in the past..)

Additional info:

For some period, it worked, I have tried different kernels.
External mike is fine

Similar issues on same laptop when working in rawhide.

My smolt profile is:
http://www.smolts.org/show?uuid=pub_4beba9fc-1cd1-4820-b948-b9ccadcaa15e
Comment 1 antonio montagnani 2009-02-23 05:32:38 EST
I have a doubt:

if I switch by software to internal mike, and I leave the external mike connected and I tap on the mike I still hear sound on the loudspeakers, as the switch should work un-properly.
Comment 2 Lennart Poettering 2009-02-24 21:59:19 EST
Sounds like a driver bug/mixer initialization issue. Reassigning to alsa/kernel.
Comment 3 Michel Alexandre Salim 2009-03-08 18:26:37 EDT
Same problem with my Dell Inspiron Mini 9:

http://www.smolts.org/client/show/pub_973d378b-2163-4d8a-a0fa-f7e0a068fa25

I have another laptop with the same problem; will send the profile later
Comment 4 Michel Alexandre Salim 2009-03-08 20:24:01 EDT
Dell Inspiron 1318:

http://www.smolts.org/client/show/pub_87ea8fb0-5744-43d3-a907-010ad841c7fc

(on Fedora 10 and Rawhide)
Comment 5 antonio montagnani 2009-03-11 02:31:56 EDT
on rawhide since 2.6.29-0.215.rc7.fc11.i686.PAE kernel, internal mike is working
Comment 6 antonio montagnani 2009-03-11 11:42:29 EDT
can you revert same patches in order to make it work also in F10???
Comment 7 antonio montagnani 2009-03-11 12:03:11 EDT
2.6.29-0.54.rc7.git3.fc10.i686.PAE that I grabbed from koij makes the mike work also in F10...

Wait for confirmation from Michel, then I will close it
Comment 8 Michel Alexandre Salim 2009-03-11 16:53:16 EDT
Mine works fine as well, though requiring some workaround:

Inspiron 1318 (STAC9228):
options snd-hda-intel model=dell-bios
digital input source: digital mic
input source: Mic

Inspiron Mini 9 (ALC268):
options snd-hda-intel model=toshiba <-- from Gentoo wiki
input source: front mic

Note You need to log in before you can comment on or make changes to this bug.