Bug 484195 - upgrade to libxml2-2.7.3 breaks gnome compilation
upgrade to libxml2-2.7.3 breaks gnome compilation
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libxml2 (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-05 05:44 EST by paolo borelli
Modified: 2009-02-05 06:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-05 06:08:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description paolo borelli 2009-02-05 05:44:14 EST
After upgrading to libxml2-2.7.3 from the F10 updates, trying to build gnome programs started failing with the following error:


Traceback (most recent call last):
  File "/opt/gnome/bin/xml2po", line 35, in <module>
    import libxml2
  File "/usr/lib64/python2.5/site-packages/libxml2.py", line 1, in <module>
    import libxml2mod
ImportError: /usr/lib64/python2.5/site-packages/libxml2mod.so: undefined symbol: xmlPreviousElementSibling
make[2]: *** [bg/gedit.xml] Error 1
make[2]: *** Waiting for unfinished jobs....
Traceback (most recent call last):
  File "/opt/gnome/bin/xml2po", line 35, in <module>
    import libxml2
  File "/usr/lib64/python2.5/site-packages/libxml2.py", line 1, in <module>
    import libxml2mod
ImportError: /usr/lib64/python2.5/site-packages/libxml2mod.so: undefined symbol: xmlPreviousElementSibling
make[2]: *** [da/gedit.xml] Error 1
make[2]: Leaving directory `/home/paolo/svn/gnome/gedit/help'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/paolo/svn/gnome/gedit'
make: *** [all] Error 2



Manually downgrading to the libxml2-2.7.2 package fixed the issue
Comment 1 paolo borelli 2009-02-05 06:08:32 EST
ops, sorry it's my fault... I forgot jhbuild doesn't pull libxml from svn anymore so the problem was due to a mismatch among the jhbuild installed version and the libxml2-python rpm.

Note You need to log in before you can comment on or make changes to this bug.