Bug 484232 - Backport improved CalDAV support from Fedora 10
Backport improved CalDAV support from Fedora 10
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution-data-server (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Milan Crha
desktop-bugs@redhat.com
:
: 498300 (view as bug list)
Depends On:
Blocks: 484252
  Show dependency treegraph
 
Reported: 2009-02-05 10:58 EST by Matthew Barnes
Modified: 2009-09-02 05:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 484252 (view as bug list)
Environment:
Last Closed: 2009-09-02 05:15:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Barnes 2009-02-05 10:58:16 EST
Evolution's CalDAV support is greatly improved in Fedora 10, and I'd like to backport it for RHEL 5.4.  This would also obsolete the evolution-webcal package.

There are two parts to the CalDAV support:

  1) A backend for evolution-data-server.  This is where most of the meat is.

  2) A plugin for evolution, which provides the UI for configuring a CalDAV
     calendar (in the "New Calendar" dialog).

Among the benefits of doing this would be better support for our own corporate Zimbra calendars on the Corporate Standard Build.

This bug is for the evolution-data-server backend.  I will file a separate bug for the evolution plugin.
Comment 1 Matthew Barnes 2009-02-10 12:09:26 EST
(In reply to comment #0)
> This would also obsolete the evolution-webcal package.

Scratch that part.  I had my facts wrong.
Comment 3 Huzaifa S. Sidhpurwala 2009-04-16 04:09:04 EDT
This package does not work well.
It hangs badly when adding an appointment, but when updating any
appointments, or refreshing from the server, it works smoothly.
Comment 4 Milan Crha 2009-04-30 05:31:52 EDT
*** Bug 498300 has been marked as a duplicate of this bug. ***
Comment 9 errata-xmlrpc 2009-09-02 05:15:00 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1259.html

Note You need to log in before you can comment on or make changes to this bug.