Bug 484248 - Cron not running multiple jobs against same script in xen DomU
Cron not running multiple jobs against same script in xen DomU
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-05 11:33 EST by ali
Modified: 2009-12-18 02:49 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 02:49:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ali 2009-02-05 11:33:12 EST
Description of problem:


crontabs-1.10-25.fc10.noarch
How reproducible:
I have a user ABC when i put cronjobs using this user crontab.I login with ABC user and do crontab -e.When i add multiple job against same script more them 10 jobs that run on same time.This is a bash script run certwatch script for different domain daily  at 09 19.But cron seems to run this job fine and no error in log but script dont show any out put after job is run in script log.In other word script dont run successfully .We recently upgraded from f8 to f10.And this problem was not in f8.I have test on number of fedora 10 system but cron dont see to work.


Steps to Reproduce:
1.Log with user ABC
2.do crontab -e
3.Add many jobs against same script like 09 19 * * * /home/YOUR_BASH_SCRIPT
4 Add more then 10 jobs.

  
Actual results:
It dont run any job given at same time againt same script

Expected results:
It should run jobs that are given same time again same script.

Additional info:
Comment 1 Tomas Mraz 2009-02-05 11:55:20 EST
I cannot reproduce this on rawhide - I tried simple job which does date >>logfile. I've added it 12 times with the crontab -e and it appears that it runs 12 times - that means the same date is appended 12 times.
Comment 2 ali 2009-02-05 11:58:58 EST
Thanks for replying

I also like to mention i am using Xen Virtual machine.
Comment 3 Marcela Mašláňová 2009-02-06 03:53:32 EST
There are some other issues with cron on xen machines. Isn't there problem with selinux? 
This test case passed just fine on QEMU virtual machine.
Comment 4 Mark McLoughlin 2009-02-06 07:36:03 EST
If this does turn out to be a xen specific issue, it will be a problem with the kernel rather than xen userspace
Comment 5 ali 2009-02-06 12:23:41 EST
Hi 


After testing few things  i am back.

1) When i run cron job with the space of 2 min under user ABC.It runs fine and no problem.

2) For testing i put the cron file in /etc/cron.d and run it on same time with user root .But same result it was not able to run the script and no error in logs.

But you can say there might be a problem in script.But this not be the case if script run from cron if i give 2 min difference between every job.And this script is not that much process hungry.

3) for testing i again today run the script on fc8 xen machine.And it runs fine.

I like to mention  kernel details of my new f10 machine

2.6.27.12-170.2.5.fc10.i686.PAE
Comment 6 Bug Zapper 2009-11-18 04:48:32 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2009-12-18 02:49:16 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.