Bug 484266 - JMS support for headers exchange
JMS support for headers exchange
Status: CLOSED DUPLICATE of bug 483750
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-java (Show other bugs)
1.1
All Linux
low Severity medium
: 1.3
: ---
Assigned To: Rajith Attapattu
Frantisek Reznicek
IG Index
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-05 13:55 EST by Arnaud Simon
Modified: 2015-11-15 19:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-27 16:06:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arnaud Simon 2009-02-05 13:55:18 EST
Description of problem:
Currently the JMS client does does not provide support for headers exchange. 

Solution:
The URL scheme should be updated to provide support for queues that are bound to headers exchanges. Something like queue.myQueue = headers://headers.exchange.name//header1=value1&header2=value2&type=all would be great
Comment 1 Rajith Attapattu 2009-03-09 15:47:46 EDT
This bz will be covered using https://bugzilla.redhat.com/show_bug.cgi?id=483750
Comment 2 Rajith Attapattu 2010-02-17 22:56:32 EST
Support for this is added via the new addressing syntax
It's available from rev 906145 and upwards in Qpid trunk.
Comment 3 Justin Ross 2011-06-27 16:06:26 EDT

*** This bug has been marked as a duplicate of bug 483750 ***

Note You need to log in before you can comment on or make changes to this bug.