Bug 484267 - Undocking the Thinkpad x61 distorts the graphical desktop
Undocking the Thinkpad x61 distorts the graphical desktop
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-i810 (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-05 13:57 EST by Siddharth Nagar
Modified: 2012-04-18 10:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 10:15:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (976 bytes, application/x-extension-conf)
2009-02-11 14:00 EST, Siddharth Nagar
no flags Details
Xorg.0.log.old (50.36 KB, text/plain)
2009-02-11 14:02 EST, Siddharth Nagar
no flags Details
Xorg.0.log (59.28 KB, text/plain)
2009-02-11 14:02 EST, Siddharth Nagar
no flags Details
screenshot (729.62 KB, image/png)
2009-02-11 14:04 EST, Siddharth Nagar
no flags Details

  None (edit)
Description Siddharth Nagar 2009-02-05 13:57:42 EST
Description of problem: Undocking the Thinkpad x61 distorts the graphical desktop and makes it unusable.


Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. Attach the laptop to the dock.
2. Start the machine and make you are logged in and the GNOME desktop is visible.
3. Undock the laptop.
  
Actual results:
The GNOME desktop becomes distorted and the taskbar appears in the middle of the screen and doesn't respond to mouse clicks.


Expected results:
The desktop should not be impacted when the machine is docked/undocked.


Additional info:
Comment 1 Matěj Cepl 2009-02-08 10:50:19 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Are you able to create screenshot of the distorted screen (just by pressing PrtScr)? Could you attach that as well, please?

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Siddharth Nagar 2009-02-11 14:00:37 EST
Created attachment 331604 [details]
xorg.conf
Comment 3 Siddharth Nagar 2009-02-11 14:02:03 EST
Created attachment 331605 [details]
Xorg.0.log.old
Comment 4 Siddharth Nagar 2009-02-11 14:02:49 EST
Created attachment 331606 [details]
Xorg.0.log
Comment 5 Siddharth Nagar 2009-02-11 14:04:05 EST
Created attachment 331607 [details]
screenshot
Comment 6 Siddharth Nagar 2009-02-11 14:06:13 EST
I have attached the requested information. Also, not sure if it matters, but my monitor supports a higher resolution than the laptop screen. After undocking, I have to press Fn+7 to turn the laptop screen on which results in the image shown in the screenshot file.
Comment 10 Ludek Smid 2010-03-11 07:25:37 EST
Since it is too late to address this issue in RHEL 5.5, it has been proposed for RHEL 5.6.  Contact your support representative if you need to escalate this issue.
Comment 11 Ludek Smid 2010-11-26 04:02:09 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red Hat Enterprise Linux 5.6 and Red Hat does not plan to fix this issue the currently developed update.

Contact your manager or support representative in case you need to escalate this bug.
Comment 12 Adam Jackson 2012-04-18 10:15:35 EDT
No further hardware enablement updates are planned for RHEL5's X stack.  If this problem still occurs in RHEL6, please update the affected product version and reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.