Bug 484270 - LiveUSB creation failed: No module named parted
LiveUSB creation failed: No module named parted
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: liveusb-creator (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: kushaldas@gmail.com
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-05 14:33 EST by Mace Moneta
Modified: 2009-02-09 16:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-09 16:57:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mace Moneta 2009-02-05 14:33:02 EST
Description of problem:

When creating a liveusb of the F11-Alpha-i686-Live.iso, the process fails with the error "No module named parted".

Version-Release number of selected component (if applicable):

liveusb-creator-3.5-1.fc10.noarch
livecd-tools-021-1.fc10.x86_64
F11-Alpha-i686-Live.iso
How reproducible:


Steps to Reproduce:
1. Run liveusb-creator on F10
2. Select image F11-Alpha-i686-Live.iso
3. Click "Create live USB"
  
Actual results:

F11-Alpha-i686-Live.iso selected
Verifying filesystem...
Verifying ISO MD5 checksum
Extracting live image to USB device...
Wrote to device at 48 MB/sec
Creating 2047MB persistent overlay
Installing bootloader...
No module named parted
LiveUSB creation failed!

Expected results:

Successful creation of the live USB

Additional info:
Comment 1 Patrick Steiner 2009-02-06 09:22:57 EST
I think you have to install pyparted

It is a parted python module.
Comment 2 Luke Macken 2009-02-06 10:16:15 EST
I fixed this issue a couple of days ago -- I will queue the updates for pushing now.
Comment 3 Mace Moneta 2009-02-06 10:34:15 EST
I installed pyparted and received another error: 

'NoneType' object is not iterable


The log:

F11-Alpha-i686-Live.iso selected
Verifying filesystem...
Verifying ISO MD5 checksum
Extracting live image to USB device...
Wrote to device at 42 MB/sec
Creating 2047MB persistent overlay
Installing bootloader...
'NoneType' object is not iterable
LiveUSB creation failed!

Is this also corrected, or should I open a different bug?
Comment 4 Mace Moneta 2009-02-06 11:16:37 EST
I installed liveusb-creator-3.5-2.fc10.noarch and the error in comment 3 is present in that version.
Comment 5 Fedora Update System 2009-02-07 17:19:07 EST
liveusb-creator-3.5-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2009-02-07 17:21:35 EST
liveusb-creator-3.5-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Mace Moneta 2009-02-07 17:55:47 EST
Problems still persist, and I made note of it in comments 3 and 4.
Comment 8 Luke Macken 2009-02-09 16:43:12 EST
(In reply to comment #3)
> I installed pyparted and received another error: 
> 
> 'NoneType' object is not iterable
> 
> 
> The log:
> 
> F11-Alpha-i686-Live.iso selected
> Verifying filesystem...
> Verifying ISO MD5 checksum
> Extracting live image to USB device...
> Wrote to device at 42 MB/sec
> Creating 2047MB persistent overlay
> Installing bootloader...
> 'NoneType' object is not iterable
> LiveUSB creation failed!
> 
> Is this also corrected, or should I open a different bug?

This looks like a different issue... could you please open a different ticket?  Thanks!
Comment 9 Mace Moneta 2009-02-09 16:57:08 EST
OK, Bug 484790 has been created.  Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.