This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 484272 - Bad metadata for tex-musixtex-doc
Bad metadata for tex-musixtex-doc
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: tex-musixtex (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Orcan Ogetbil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-05 15:09 EST by J. Randall Owens
Modified: 2009-02-05 15:23 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-05 15:19:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J. Randall Owens 2009-02-05 15:09:04 EST
Description of problem:
When I try installing tex-musixtex-doc with smart package manager, it complains that no package provides tex-musixtex-0.114-3.fc9, even though the package that seems to match that description is right there next to it (in alphabetical order).
I scanned the XML metadata for the updates-9-i386 repository, and found that while tex-musixtex has an rpm:provides 'rpm:entry name="tex-musixtex" flags="EQ" epoch="0" ver="0.114" rel="3.fc9"/' (imagine angle brackets instead of single quotes), tex-musixtex-doc rpm:requires 'rpm:entry name="tex-musixtex=0.114-3.fc9"/'.  I'm not intimately familiar with the repo metadata format, but perhaps this difference of treating it all as one long name, vs. breaking it up into components, causes smart to consider the require unfulfilled.
...checked with `yum install` instead of smart, and it's affected by this, too.

Version-Release number of selected component (if applicable):
tex-musixtex(-doc)-0.114-3.fc9

How reproducible:
Attempt to install tex-musixtex-doc while tex-musixtex is available (for a package manager that will handle dependencies) or already installed.

Steps to Reproduce:
1. (smart|yum) install tex-musixtex-doc
  
Actual results:
tex-musixtex-doc-0.114-3.fc9.noarch from updates-newkey has depsolving problems
  --> Missing Dependency: tex-musixtex=0.114-3.fc9 is needed by package tex-musixtex-doc-0.114-3.fc9.noarch (updates-newkey)
Error: Missing Dependency: tex-musixtex=0.114-3.fc9 is needed by package tex-musixtex-doc-0.114-3.fc9.noarch (updates-newkey)

Expected results:
tex-musixtex-doc installed

Additional info:
This might well not be a problem with tex-musixtex at all, but rather whichever form of createrepo and the like is used in the fedoraproject.org repositories.  Could be the smart package manager on my end, too.  But I thought I'd start small, with the package directly affected.
Comment 1 Orcan Ogetbil 2009-02-05 15:19:46 EST
Thanks for the report. It was a packaging bug by me. The fix is described in bug 481071#c12 . I committed the fix and built tex-musixtex-0.114-4 . It should hit to repos in a few days. In the meanwhile you can grab the fixed version from koji.
Comment 2 J. Randall Owens 2009-02-05 15:21:55 EST
On second thought, refreshing my memory at some of the RPM docs, it might be as simple as putting spaces around the equal sign in "Requires:  %{name}=%{version}-%{release}" in the specfile.  At least, the examples I saw have spaces around it (and inequality comparisons, too).
Comment 3 J. Randall Owens 2009-02-05 15:23:59 EST
OK, I wasn't checking the package review, of course.  Looks like I found the problem pretty well, at least!  If a bit late.

Note You need to log in before you can comment on or make changes to this bug.