Bug 484342 - Get Traceback messages when finish creating VMs
Get Traceback messages when finish creating VMs
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.3
All Linux
medium Severity high
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-06 05:19 EST by Yolkfull Chow
Modified: 2009-12-14 16:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 14:26:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yolkfull Chow 2009-02-06 05:19:00 EST
Description of problem:
Seems that the arg in class DistroInstaller in DistroManager.py is "os_type" which is not match with that arg in Guest.py : "_os_type".The traceback messages are as following:

Unable to complete install 'exceptions.AttributeError 'DistroInstaller' object has no attribute '_os_type'
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 627, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 950, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 986, in _do_install
    install_xml = self.get_config_xml()
  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 904, in get_config_xml
    osblob = self._get_osblob(osblob_install)
  File "/usr/lib/python2.4/site-packages/virtinst/FullVirtGuest.py", line 107, in _get_osblob
    arch = self.arch, loader = self.loader, conn = self.conn)
  File "/usr/lib/python2.4/site-packages/virtinst/DistroManager.py", line 348, in _get_osblob
    kernel=self.install, bootdev=bootdev)
  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 437, in _get_osblob_helper
    os_type = self.os_type
  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 362, in get_os_type
    return self._os_type
AttributeError: 'DistroInstaller' object has no attribute '_os_type'
'

Version-Release number of selected component (if applicable):
kvm-83-1.el5
python-virtinst-0.400.1-1.el5

How reproducible:
Everytime

Steps to Reproduce:
1. Follow the instructions to the last step
2. click "Finish" button 
3.
  
Actual results:
Get traceback and cannot finish creating VMs.

Expected results:
Could finish creating VMs.

Additional info:
Comment 1 Cole Robinson 2009-02-13 14:26:57 EST
Thanks for the report, I fixed this upstream:

http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virtinst--devel/rev/fc17a264e2a5

Since you seem to be using latest upstream virtinst, this isn't relevant for RHEL, so I'll close as UPSTREAM.

Note You need to log in before you can comment on or make changes to this bug.