Bug 484451 - gdm / policykit avc messages
gdm / policykit avc messages
Status: CLOSED DUPLICATE of bug 480847
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-06 16:03 EST by drago01
Modified: 2009-02-09 04:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-09 04:54:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description drago01 2009-02-06 16:03:34 EST
Description of problem:

I am seeing AVCs generated from gdm/policykit in my logs:

type=1400 audit(1233952439.787:4): avc:  denied  { write } for  pid=2714 comm="polkit-read-aut" path="/var/log/gdm/:0-greeter.log" dev=sda2 ino=7766033 scontext=system_u:system_r:polkit_auth_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xserver_log_t:s0 tclass=file
type=1400 audit(1233952439.812:5): avc:  denied  { write } for  pid=2715 comm="polkit-read-aut" path="/var/log/gdm/:0-greeter.log" dev=sda2 ino=7766033 scontext=system_u:system_r:polkit_auth_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xserver_log_t:s0 tclass=file
type=1400 audit(1233952442.652:6): avc:  denied  { write } for  pid=2747 comm="polkit-read-aut" path="/var/log/gdm/:0-greeter.log" dev=sda2 ino=7766033 scontext=system_u:system_r:polkit_auth_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xserver_log_t:s0 tclass=file
type=1400 audit(1233952442.833:7): avc:  denied  { write } for  pid=2748 comm="polkit-read-aut" path="/var/log/gdm/:0-greeter.log" dev=sda2 ino=7766033 scontext=system_u:system_r:polkit_auth_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xserver_log_t:s0 tclass=file
type=1400 audit(1233952446.209:8): avc:  denied  { write } for  pid=2751 comm="polkit-read-aut" path="/var/log/gdm/:0-greeter.log" dev=sda2 ino=7766033 scontext=system_u:system_r:polkit_auth_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xserver_log_t:s0 tclass=file



Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.5.13-41.fc10.noarch

How reproducible:
Always

Steps to Reproduce:
1. boot
2. notice the errors in the log
  
Actual results:

AVC messages

Expected results:

No AVCs.

Additional info:

audit2allow -d


#============= polkit_auth_t ==============
allow polkit_auth_t xserver_log_t:file write;
Comment 1 Anthony Messina 2009-02-08 07:27:16 EST
I can confirm this as well.
Comment 2 Miroslav Grepl 2009-02-09 04:54:02 EST

*** This bug has been marked as a duplicate of bug 480847 ***

Note You need to log in before you can comment on or make changes to this bug.