Bug 484490 - No PHP Shared Modules for ZTS
No PHP Shared Modules for ZTS
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-07 06:01 EST by Ilya Eremin
Modified: 2009-05-28 06:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-28 06:23:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ilya Eremin 2009-02-07 06:01:11 EST
It is nice to see that in the latest rawhide build of php there's a ZTS extension, which let's us use the worker MPM. But the problem is, none of the extensions, have ZTS builds (like php-mysql for example), so right now a ZTS set up with those RPMs is more or less useless.
Comment 1 Joe Orton 2009-05-28 06:23:12 EDT
This is intentional.  Upstream do not support ZTS builds; the ZTS build included in Fedora is experimental.

If you wish to have ZTS builds supported with the normal range of modules, you need to work on that upstream.

Note You need to log in before you can comment on or make changes to this bug.