Bug 484586 - Suggestion: Stop KMail from forgetting passwords when kwallet is closed.
Suggestion: Stop KMail from forgetting passwords when kwallet is closed.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-08 13:38 EST by Stan Trzmiel
Modified: 2009-07-27 06:21 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-27 06:21:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stan Trzmiel 2009-02-08 13:38:40 EST
Description of problem:
I'd suggest a change in Kmail behaviour when accounts passwords are stored in KWallet and Kwallet is not open.

Actual results:
KMail forgets the stored passwords when it's unable to access KWallet

Expected results:
KMail shouldn't attempt to open KWallet just in two cases:
 a) "remember password" option is not checked (user didn't turn it on or disabled it manually)
 b) Use Kwallet option was turned off by user.

In any other case KMail should keep nagging about KWallet password or offer "go offline" option


Rationale:
Now it's possible to delete passwords stored in KWallet without opening KWallet at all.
User may loose his passwords when KMail won't get access to KWallet (ie. user logged out without typing the KWallet password, xorg crashed etc...)

It became more important with KDE 4.2.0-2 when at logout KWallet is closed before KMail, thus resulting with loss of passwords every logout.


Version-Release number of selected component (if applicable):
kdepim 4.2.0-2 (Actually it applies to any verion of kdepim 3.5 including)
Comment 1 Rex Dieter 2009-02-08 16:04:14 EST
We're not in any position to implement this suggestion... Please do so by reporting upstream, potentially do kdepim mailing list or to bugs.kde.org.
Comment 2 Rex Dieter 2009-02-08 16:07:48 EST
Fwiw, my understanding is that any kwallet-using app should (re)start kwallet on-demand as needed.  So, if what your describe is happening, kmail not reaching kwallet when needed, seems to be a bug to me.
Comment 3 Stan Trzmiel 2009-02-08 17:54:45 EST
Yup that's what I think is reasonable.
It's not a bug per se, b'cause IIRC KMail always worked this way. But it's annoying, when stored passwords can be lost just b'cause you decided to not open the password manager once.

launch KMail (in my case it's from autostart or resumed from prevoius session),  the KWallet dialog pop-up but I closed it without entering password or just ignored it for some period of time (most likely next scheduled attempt to check mail). 

In KDEPIM up to 4.1.4 passwords are still in the wallet (you can browse them) but KMail will start to ask for password for every configured account, and won't check Wallet anymore, unless you store them again. This resultd in duplicate entries in KWallet

From KDE 4.1.5 I observed that after you deny access to KWallet, passwords will be deleted.

In my opinion apps should keep tryin to open KWallet as they were configured untill you let them in or order to stop using it.
"Go offline" option can be usefull to hush the application without breaking your preferences.
Comment 4 Stan Trzmiel 2009-02-08 17:58:11 EST
(In reply to comment #1)
> We're not in any position to implement this suggestion... Please do so by
> reporting upstream, potentially do kdepim mailing list or to bugs.kde.org.

Ok I'll try to ask devs at kde.org TNX for this tip.
Comment 5 Stan Trzmiel 2009-07-27 06:21:22 EDT
Ok I'm closing this one, maybe it's not perfect, but KMail stopped loosing password so I'm happy the way it is.

Note You need to log in before you can comment on or make changes to this bug.