Bug 484601 - yum doesn't accept listfiles as action
yum doesn't accept listfiles as action
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-08 16:46 EST by Tobias Mueller
Modified: 2014-01-21 18:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-09 01:38:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tobias Mueller 2009-02-08 16:46:45 EST
Description of problem:
I want to know which files a package installed. I don't want to know about other tools besides yum, because it costs my precious time to learn about many tools.

Version-Release number of selected component (if applicable):
$ yum info yum
Loaded plugins: priorities, refresh-packagekit
96 packages excluded due to repository priority protections
Installed Packages
Name       : yum
Arch       : noarch
Version    : 3.2.21
Release    : 2.fc10
Size       : 3.1 M
Repo       : installed
Summary    : RPM installer/updater
URL        : http://yum.baseurl.org/
License    : GPLv2+
Description: Yum is a utility that can check for and automatically download and
           : install updated RPM packages. Dependencies are obtained and
           : downloaded automatically prompting the user as necessary.



How reproducible:
execute "yum listfiles ca-certificates" and see it FAILing.

Steps to Reproduce:
1. exec yum listfiles ca-certificates
2.
3.
  
Actual results:
Yum fails because it doesn't know about this command "listfiles"

Expected results:
I expected yum to display the files the package "ca-certificates" installed.

Additional info:
I'd also appreciate if "files", "showfiles" and the like were aliased to "listfiles"
Comment 1 James Antill 2009-02-09 01:38:07 EST
Why do you think "yum listfiles" is costs less time to learn than "repoquery --list"?
Comment 2 seth vidal 2009-02-09 11:43:11 EST
if you want to know about what files are currently installed you can also run:

rpm -ql pkgname

if you want to know what package an installed file comes from you can run:

rpm -qf /path/to/file
Comment 3 Tobias Mueller 2009-02-12 16:09:07 EST
Hi James,

thanks for you quick response.

I think it's rather obvious why "yum listfiles" costs less time: Because yum is the only interface to the package management for me. When I want to do anything with packages, I look at yum first. I really think this is pretty reasonable, since it already does the most important stuff. I also think/know that many other Fedora users see it the same way.

So this is an usability issue as well. The higher the hurdle to take is, the more annoying or cumbersome is it to fulfil a task. And the need to use different tools then *the* package-manager is of course a higher hurdle which takes thus more time (to learn, to use, to remember, ...). 

Getting from "yum" to "repoquery" is rather hard, because repoquery is only referenced as "See Also" in the manpage (among 10 other references). I'd love to see at least a hint like "Please use ,,repoquery'' in order to do this operation" if I do a "yum listfiles".

I am thus reopening this issue.^U
I can't reopen this issue, so please do it for me.

Note You need to log in before you can comment on or make changes to this bug.