Bug 484619 - yum upgrade fails on dependency problems in F11/alpha
yum upgrade fails on dependency problems in F11/alpha
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i386 Linux
high Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-08 21:24 EST by Andrew Hecox
Modified: 2014-01-21 18:08 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-11 22:10:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Hecox 2009-02-08 21:24:20 EST
installing a new F11/alpha system; running yum -y update fails with the following messages:

--> Finished Dependency Resolution
f-spot-0.5.0.3-5.fc11.i386 from installed has depsolving problems
  --> Missing Dependency: mono(Mono.Addins.Gui) = 0.3.0.0 is needed by package f-spot-0.5.0.3-5.fc11.i386 (installed)
tomboy-0.13.4-1.fc11.i386 from rawhide has depsolving problems
  --> Missing Dependency: mono(Mono.Addins.Setup) = 0.3.0.0 is needed by package tomboy-0.13.4-1.fc11.i386 (rawhide)
f-spot-0.5.0.3-5.fc11.i386 from installed has depsolving problems
  --> Missing Dependency: mono(Mono.Addins) = 0.3.0.0 is needed by package f-spot-0.5.0.3-5.fc11.i386 (installed)
frysk-0.4-4.fc11.i386 from installed has depsolving problems
  --> Missing Dependency: libgcj.so.9 is needed by package frysk-0.4-4.fc11.i386 (installed)
f-spot-0.5.0.3-5.fc11.i386 from installed has depsolving problems
  --> Missing Dependency: mono(Mono.Addins.Setup) = 0.3.0.0 is needed by package f-spot-0.5.0.3-5.fc11.i386 (installed)
tomboy-0.13.4-1.fc11.i386 from rawhide has depsolving problems
  --> Missing Dependency: mono(Mono.Addins.Gui) = 0.3.0.0 is needed by package tomboy-0.13.4-1.fc11.i386 (rawhide)
tomboy-0.13.4-1.fc11.i386 from rawhide has depsolving problems
  --> Missing Dependency: mono(Mono.Addins) = 0.3.0.0 is needed by package tomboy-0.13.4-1.fc11.i386 (rawhide)
ibus-qt-0.1.1.20081023-3.fc11.i386 from installed has depsolving problems
  --> Missing Dependency: ibus = 0.1.1.20081023-3.fc11 is needed by package ibus-qt-0.1.1.20081023-3.fc11.i386 (installed)
Error: Missing Dependency: mono(Mono.Addins) = 0.3.0.0 is needed by package f-spot-0.5.0.3-5.fc11.i386 (installed)
Error: Missing Dependency: mono(Mono.Addins.Setup) = 0.3.0.0 is needed by package tomboy-0.13.4-1.fc11.i386 (rawhide)
Error: Missing Dependency: mono(Mono.Addins.Setup) = 0.3.0.0 is needed by package f-spot-0.5.0.3-5.fc11.i386 (installed)
Error: Missing Dependency: mono(Mono.Addins.Gui) = 0.3.0.0 is needed by package f-spot-0.5.0.3-5.fc11.i386 (installed)
Error: Missing Dependency: mono(Mono.Addins) = 0.3.0.0 is needed by package tomboy-0.13.4-1.fc11.i386 (rawhide)
Error: Missing Dependency: libgcj.so.9 is needed by package frysk-0.4-4.fc11.i386 (installed)
Error: Missing Dependency: ibus = 0.1.1.20081023-3.fc11 is needed by package ibus-qt-0.1.1.20081023-3.fc11.i386 (installed)
Error: Missing Dependency: mono(Mono.Addins.Gui) = 0.3.0.0 is needed by package tomboy-0.13.4-1.fc11.i386 (rawhide)

taking the example of mono-addins, the dependency appears to be available locally:

[test@desktop ~]$ rpm -q --provides mono-addins
mono(Mono.Addins) = 0.3.0.0
mono(Mono.Addins.Gui) = 0.3.0.0
mono(Mono.Addins.Setup) = 0.3.0.0
mono(mautil) = 1.0.3117.12796
mono(policy.0.2.Mono.Addins) = 0.0.0.0
mono(policy.0.2.Mono.Addins.Gui) = 0.0.0.0
mono(policy.0.2.Mono.Addins.Setup) = 0.0.0.0
mono-addins = 0.3.1-2.2.fc10
mono-addins(x86-32) = 0.3.1-2.2.fc10

so I'm filing this under yum ... that said, I really have no idea where this is breaking down. Removing the failing packages resolves the issue (provided you don't need them).
Comment 1 STEVEN WARD 2009-02-09 10:26:20 EST
Hi to all,
         I'm running Fedora 11 Rawhide,and I'm getting similar dependency problems as well.Here is my yum update output:

[root@localhost ~]# yum clean all
Loaded plugins: dellsysidplugin2, fastestmirror, presto, refresh-packagekit
Cleaning up Everything
Cleaning up list of fastest mirrors
[root@localhost ~]# yum update
Loaded plugins: dellsysidplugin2, fastestmirror, presto, refresh-packagekit
Determining fastest mirrors
rawhide-source/metalink                                                                                                                                                                                                             |  11 kB     00:00
rawhide-debuginfo/metalink                                                                                                                                                                                                          |  11 kB     00:00
rawhide/metalink                                                                                                                                                                                                                    |  12 kB     00:00
 * rawhide-source: mirror.atrpms.net
 * rpmfusion-free-rawhide: rpmfusion.famillecollet.com
 * rawhide-debuginfo: mirror.atrpms.net
 * rpmfusion-nonfree-rawhide: rpmfusion.famillecollet.com
 * rawhide: mirror.atrpms.net
Setting up and reading Presto delta metadata
rawhide-source                                                                                                                                                                                                                      | 2.7 kB     00:00
rawhide-source/primary_db                                                                                                                                                                                                           | 2.1 MB     02:26
No Presto metadata available for rawhide-source
rpmfusion-free-rawhide                                                                                                                                                                                                              | 2.7 kB     00:00
rpmfusion-free-rawhide/primary_db                                                                                                                                                                                                   | 323 kB     00:01
No Presto metadata available for rpmfusion-free-rawhide
adobe-linux-i386                                                                                                                                                                                                                    |  951 B     00:00
adobe-linux-i386/primary                                                                                                                                                                                                            |  10 kB     00:00
No Presto metadata available for adobe-linux-i386
rawhide-debuginfo                                                                                                                                                                                                                   | 2.7 kB     00:00
rawhide-debuginfo/primary_db                                                                                                                                                                                                        | 1.1 MB     01:13
No Presto metadata available for rawhide-debuginfo
rpmfusion-nonfree-rawhide                                                                                                                                                                                                           | 2.7 kB     00:00
rpmfusion-nonfree-rawhide/primary_db                                                                                                                                                                                                | 124 kB     00:01
No Presto metadata available for rpmfusion-nonfree-rawhide
rawhide                                                                                                                                                                                                                             | 3.4 kB     00:00
rawhide/primary_db                                                                                                                                                                                                                  | 7.4 MB     08:28
No Presto metadata available for rawhide
adobe-linux-i386                                                                                                                                                                                                                                     17/17
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package ImageMagick.i386 0:6.4.5.5-8.fc11 set to be updated
---> Package ImageMagick-perl.i386 0:6.4.5.5-8.fc11 set to be updated
---> Package guile.i386 5:1.8.6-2.fc11 set to be updated
---> Package libcanberra.i386 0:0.11-6.fc11 set to be updated
--> Processing Dependency: libgcj.so.9 for package: frysk
---> Package libgcj.i386 0:4.4.0-0.16 set to be updated
---> Package libgphoto2.i386 0:2.4.4-1.fc11 set to be updated
---> Package libtool-ltdl.i386 0:2.2.6-9.fc11 set to be updated
--> Processing Dependency: libltdl.so.3 for package: google-gadgets-qt
--> Processing Dependency: libltdl.so.3 for package: google-gadgets
---> Package pulseaudio.i386 0:0.9.14-2.fc11 set to be updated
---> Package pulseaudio-core-libs.i386 0:0.9.14-2.fc11 set to be updated
---> Package sox.i386 0:14.2.0-1.fc11 set to be updated
rawhide-debuginfo/filelists_db                                                                                                                                                                                                      | 6.3 MB     06:15
rpmfusion-nonfree-rawhide/filelists_db                                                                                                                                                                                              |  66 kB     00:00
rpmfusion-free-rawhide/filelists_db                                                                                                                                                                                                 | 310 kB     00:00
rawhide/filelists_db                                                                                                                                                                                                                |  12 MB     14:32
adobe-linux-i386/filelists                                                                                                                                                                                                          | 173 kB     00:04
--> Finished Dependency Resolution
google-gadgets-qt-0.10.5-2.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libltdl.so.3 is needed by package google-gadgets-qt-0.10.5-2.fc10.i386 (installed)
frysk-0.4-4.fc11.i386 from installed has depsolving problems
  --> Missing Dependency: libgcj.so.9 is needed by package frysk-0.4-4.fc11.i386 (installed)
google-gadgets-0.10.5-2.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libltdl.so.3 is needed by package google-gadgets-0.10.5-2.fc10.i386 (installed)
Error: Missing Dependency: libgcj.so.9 is needed by package frysk-0.4-4.fc11.i386 (installed)
Error: Missing Dependency: libltdl.so.3 is needed by package google-gadgets-qt-0.10.5-2.fc10.i386 (installed)
Error: Missing Dependency: libltdl.so.3 is needed by package google-gadgets-0.10.5-2.fc10.i386 (installed)
You have new mail in /var/spool/mail/root
[root@localhost ~]#

I hope the problem will be resolved soon.

Regards,
       STEVE666
Comment 2 Jeff Peek 2009-02-10 10:25:07 EST
Following a yum update, I also get missing dependency resolution messages, so I did a yum install of the missing dependency and get the following

--> Finished Dependency Resolution
ibus-qt-0.1.1.20081023-3.fc11.i386 from installed has depsolving problems
  --> Missing Dependency: ibus = 0.1.1.20081023-3.fc11 is needed by package ibus-qt-0.1.1.20081023-3.fc11.i386 (installed)
Error: Missing Dependency: ibus = 0.1.1.20081023-3.fc11 is needed by package ibus-qt-0.1.1.20081023-3.fc11.i386 (installed)
You have mail in /var/spool/mail/root
[root@mavericks ~]# yum -y install ibus
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package ibus.i386 0:1.1.0.20090205-1.fc11 set to be updated
--> Processing Dependency: ibus = 0.1.1.20081023-3.fc11 for package: ibus-gtk
--> Processing Dependency: ibus = 0.1.1.20081023-3.fc11 for package: ibus-qt
--> Running transaction check
--> Processing Dependency: ibus = 0.1.1.20081023-3.fc11 for package: ibus-qt
---> Package ibus-gtk.i386 0:1.1.0.20090205-1.fc11 set to be updated
--> Finished Dependency Resolution
ibus-qt-0.1.1.20081023-3.fc11.i386 from installed has depsolving problems
  --> Missing Dependency: ibus = 0.1.1.20081023-3.fc11 is needed by package ibus-qt-0.1.1.20081023-3.fc11.i386 (installed)
Error: Missing Dependency: ibus = 0.1.1.20081023-3.fc11 is needed by package ibus-qt-0.1.1.20081023-3.fc11.i386 (installed)
[root@mavericks ~]# 

Regards,
Comment 3 seth vidal 2009-02-10 10:34:28 EST
Looks like ibus-qt existed for a very short while then was removed. I'll cc the ibus maintainer - maybe they can explain it b/c the changelog in the spec file sure doesn't.

Nevertheles - since nothing obsoletes it and it needs to go away just run:
yum remove ibus-qt


Phuang: did ibus-qt go away for a reason and if so - why not obsolete it by something else?
Comment 4 Peng Huang 2009-02-10 22:38:53 EST
I added obsoletes: ibus-qt <= 1.1.0. and will build it soon.
Comment 5 Jeff Peek 2009-02-11 21:29:26 EST
Seth,
Thanks.  removing ibus-qt did the trick.....

Jeff

Note You need to log in before you can comment on or make changes to this bug.