Bug 48465 - IDE CD-ROM has DMA problems and needs to be blacklisted
IDE CD-ROM has DMA problems and needs to be blacklisted
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-10 14:47 EDT by Marco Tului
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-18 15:53:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marco Tului 2001-07-10 14:47:12 EDT
Description of Problem:

I've downloaded the first iso cd image (or the image of first cd) of RedHat Linux 7.1 for i386 from the URL (of a mirror) 
ftp://softcity.iol.it/pub/redhat/redhat/redhat-7.1-en/iso/i386/
I've dowloaded it under Windows 98, by the ftp client program named "CoffeeCup Free FTP" (and I've done some resume), by an adsl internet 
connection.

But, after I've writed it on a cd-r, and I've started the installation process, after few seconds the installer breaks down, and automatically 
generate a text file for bugzilla (writed automatically in a floppy disk).
This is the text:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 520, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 1126, in run
    rc = apply (step[1](), args)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/textw/packages_text.py", line 33, in __call__
    todo.getCompsList()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 769, in getCompsList
    self.comps = self.method.readComps(self.hdList)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/image.py", line 17, in readComps
    return ComponentSet(self.tree + '/RedHat/base/comps', hdlist)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/comps.py", line 542, in __init__
    self.readCompsFile(file, self.packages)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/comps.py", line 409, in readCompsFile
    file = urllib.urlopen(filename)
  File "/usr/lib/python1.5/site-packages/urllib.py", line 57, in urlopen
    _urlopener = FancyURLopener()
  File "/usr/lib/python1.5/site-packages/urllib.py", line 447, in __init__
    apply(URLopener.__init__, (self,) + args)
  File "/usr/lib/python1.5/site-packages/urllib.py", line 92, in __init__
    self.__unlink = os.unlink # See cleanup()
NameError: s
Local variables in innermost frame:
proxies: {}
server_version: Python-urllib/1.10
self: <urllib.FancyURLopener instance at 85628a8>
ToDo object:
(itodo ToDo p1 (dp2 S'resState'
p3
S''
sS'progressWindow'
p4
NsS'setupFilesystems'
p5
I1
sS'monitorVsync'
p6
S''
sS'videoCardStateNode'
p7
S''
sS'serial'
p8
I0
sS'ddruidReadOnly'
p9
I0
sS'bootdisk'
p10
I0
sS'videoRamState'
p11
S''
sS'monitorOriginalName'
p12
S''
sS'language'
p13
(itodo
Language
(dp14
S'langInfoByName'
p15
(dp16
S'Arabic (Yemen)'
p17
(S'ar_YE'
S'iso06'
S'LatArCyrHeb-16'
tsS'Spanish (Argentina)'
p18
(S'es_AR'
S'iso01'
S'lat0-sun16'
tsS'Italian (Italy)'
p19
(S'it_IT@euro'
p20
S'iso15'
p21
S'lat0-sun16'
p22
tsS'Arabic (Lebanon)'
p23
(S'ar_LB'
S'iso06'
S'LatArCyrHeb-16'
tsS'Spanish 
(Guatemala)'
p24
(S'es_GT'
S'iso01'
S'lat0-sun16'
tsS'Malay (Malaysia)'
p25
(S'ms_MY'
S'iso01'
S'lat0-sun16'
tsS'Arabic (Libyan 
Arab Jamahiriya)'
p26
(S'ar_LY'
S'iso06'
S'LatArCyrHeb-16'
tsS'Arabic (Oman)'
p27
(S'ar_OM'
S'iso06'
S'LatArCyrHeb-16'
tsS'Arabic (Iraq)'
p28
(S'ar_IQ'
S'iso06'
S'LatArCyrHeb-16'
tsS'Arabic (Kuwait)'
p29
(S'ar_KW'
S'iso06'
S'LatArCyrHeb-16'
tsS'English (South Africa)'
p30
(S'en_ZA'
S'iso01'
S'lat0-sun16'
tsS'French (Switzerland)'
p31
(S'fr_CH'
S'iso01'
S'lat0-sun16'
tsS'Arabic (Bahrein)'
p32
(S'ar_BH'
S'iso06'
S'LatArCyrHeb-16'
tsS'Croatian'
p33
(S'hr_HR'
S'iso02'
S'lat2-sun16'
tsS'French 
(France)'
p34
(S'fr_FR@euro'
S'iso15'
S'lat0-sun16'
tsS'Greenlandic (Greenland)'
p35
(S'kl_GL'
S'iso01'
S'lat0-sun16'
tsS'Korean 
(Republic of Korea)'
p36
(S'ko_KR.euckr'
S'iso01'
S'lat0-16'
tsS'Ukrainian'
p37
(S'uk_UA'
S'koi8-u'
S'cyr-sun16'
tsS'Spanish 
(Mexico)'
p38
(S'es_MX'
S'iso01'
S'lat0-sun16'
tsS'Greek'
p39
(S'el_GR'
S'iso07'
S'gr.f16'
tsS'Spanish (El Salvador)'
p40
(S'es_SV'
S'iso01'
S'lat0-sun16'
tsS'Spanish (Peru)'
p41
(S'es_PE'
S'iso01'
S'lat0-sun16'
tsS'Spanish (Honduras)'
p42
(S'es_HN'
S'iso01'
S'lat0-sun16'
tsS'Spanish (Costa Rica)'
p43
(S'es_CR'
S'iso01'
S'lat0-sun16'
tsS'English (Denmark)'
p44
(S'en_DK'
S'iso01'
S'lat0-sun16'
tsS'Dutch (Netherlands)'
p45
(S'nl_NL@euro'
S'iso15'
S'lat0-sun16'
tsS'Serbian (Yugoslavia)'
p46
(S'sr_YU@cyrillic'
S'iso05'
S'cyr-sun16'
tsS'Russian (Ukraine)'
p47
(S'ru_UA'
S'koi8-u'
S'cyr-sun16'
tsS'Portuguese 
(Portugal)'
p48
(S'pt_PT@euro'
S'iso15'
S'lat0-sun16'
tsS'Afrikaans (South Africa)'
p49
(S'af_ZA'
S'iso01'
S'lat0-sun16'
tsS'Norwegian'
p50
(S'no_NO'
S'iso01'
S'lat0-sun16'
tsS'Arabic (Morocco)'
p51
(S'ar_MA'
S'iso06'
S'LatArCyrHeb-16'
tsS'English 
(Philippines)'
p52
(S'en_PH'
S'iso01'
S'lat0-sun16'
tsS'Arabic (Algeria)'
p53
(S'ar_DZ'
S'iso06'
S'LatArCyrHeb-16'
tsS'Indonesian'
p54
(S'id_ID'
S'iso01'
S'lat0-sun16'
tsS'Danish'
p55
(S'da_DK'
S'iso01'
S'lat0-sun16'
tsS'Chinese (Taiwan 
R.O.C.)'
p56
(S'zh_TW.euctw'
S'iso01'
S'lat0-16'
tsS'Faroese (Faroe Islands)'
p57
(S'fo_FO'
S'iso01'
S'lat0-sun16'
tsS'Galician 
(Spain)'
p58
(S'gl_ES@euro'
S'iso15'
S'lat0-sun16'
tsS'English (New Zealand)'
p59
(S'en_NZ'
S'iso01'
S'lat0-sun16'
tsS'Spanish 
(Bolivia)'
p60
(S'es_BO'
S'iso01'
S'lat0-sun16'
tsS'Cornish (Britain)'
p61
(S'kw_GB'
S'iso01'
S'lat0-sun16'
tsS'Arabic (United Arab 
Emirates)'
p62
(S'ar_AE'
S'iso06'
S'LatArCyrHeb-16'
tsS'German (Austria)'
p63
(S'de_AT@euro'
S'iso15'
S'lat0-sun16'
tsS'Romanian'
p64
(S'ro_RO'
S'iso02'
S'lat2-sun16'
tsS'Spanish (Paraguay)'
p65
(S'es_PY'
S'iso01'
S'lat0-sun16'
tsS'Hebrew 
(Israel)'
p66
(S'he_IL'
S'iso08'
S'LatArCyrHeb-16'
tsS'English (USA)'
p67
(S'en_US'
S'iso01'
S'lat0-sun16'
tsS'Spanish (USA)'
p68
(S'es_US'
S'iso01'
S'lat0-sun16'
tsS'Portuguese (Brasil)'
p69
(S'pt_BR'
S'iso01'
S'lat0-sun16'
tsS'Spanish (Equador)'
p70
(S'es_EC'
S'iso01'
S'lat0-sun16'
tsS'Polish'
p71
(S'pl_PL'
S'iso02'
S'lat2-sun16'
tsS'Slovak'
p72
(S'sk_SK'
S'iso02'
S'lat2-sun16'
tsS'Macedonian'
p73
(S'mk_MK'
S'iso05'
S'cyr-sun16'
tsS'Spanish (Spain)'
p74
(S'es_ES@euro'
S'iso15'
S'lat0-sun16'
tsS'Spanish (Chile)'
p75
(S'es_CL'
S'iso01'
S'lat0-sun16'
tsS'Arabic (Syrian Arab Republic)'
p76
(S'ar_SY'
S'iso06'
S'LatArCyrHeb-16'
tsS'Czech'
p77
(S'cs_CZ'
S'iso02'
S'lat2-sun16'
tsS'Irish'
p78
(S'ga_IE@euro'
S'iso15'
S'lat0-sun16'
tsS'Arabic (Jordan)'
p79
(S'ar_JO'
S'iso06'
S'LatArCyrHeb-16'
tsS'Italian (Switzerland)'
p80
(S'it_CH'
S'iso01'
S'lat0-sun16'
tsS'German (Belgium)'
p81
(S'de_BE@euro'
S'iso15'
S'lat0-sun16'
tsS'Albanian'
p82
(S'sq_AL'
S'iso01'
S'lat0-sun16'
tsS'Finnish'
p83
(S'fi_FI@euro'
S'iso15'
S'lat0-sun16'
tsS'Swedish (Sweden)'
p84
(S'sv_SE'
S'iso01'
S'lat0-sun16'
tsS'English (Singapore)'
p85
(S'en_SG'
S'iso01'
S'lat0-sun16'
tsS'Dutch (Belgium)'
p86
(S'nl_BE@euro'
S'iso15'
S'lat0-sun16'
tsS'Spanish (Panama)'
p87
(S'es_PA'
S'iso01'
S'lat0-sun16'
tsS'Spanish (Venezuela)'
p88
(S'es_VE'
S'iso01'
S'lat0-sun16'
tsS'English (Great Britain)'
p89
(S'en_GB'
S'iso01'
S'lat0-sun16'
tsS'Russian'
p90
(S'ru_RU.koi8r'
S'koi8-u'
S'cyr-sun16'
tsS'Norwegian, Nynorsk (Norway)'
p91
(S'nn_NO'
S'iso01'
S'lat0-sun16'
tsS'English (Zimbabwe)'
p92
(S'en_ZW'
S'iso01'
S'lat0-sun16'
tsS'Spanish (Nicaragua)'
p93
(S'es_NI'
S'iso01'
S'lat0-sun16'
tsS'German (Luxemburg)'
p94
(S'de_LU@euro'
S'iso15'
S'lat0-sun16'
tsS'Spanish (Colombia)'
p95
(S'es_CO'
S'iso01'
S'lat0-sun16'
tsS'Basque (Spain)'
p96
(S'eu_ES@euro'
S'iso15'
S'lat0-sun16'
tsS'Arabic (Qatar)'
p97
(S'ar_QA'
S'iso06'
S'LatArCyrHeb-16'
tsS'Arabic (Egypt)'
p98
(S'ar_EG'
S'iso06'
S'LatArCyrHeb-16'
tsS'French (Belgium)'
p99
(S'fr_BE@euro'
S'iso15'
S'lat0-sun16'
tsS'English (Ireland)'
p100
(S'en_IE@euro'
S'iso15'
S'lat0-sun16'
tsS'Hungarian'
p101
(S'hu_HU'
S'iso02'
S'lat2-sun16'
tsS'Arabic (Tunisia)'
p102
(S'ar_TN'
S'iso06'
S'LatArCyrHeb-16'
tsS'French (Luxemburg)'
p103
(S'fr_LU@euro'
S'iso15'
S'lat0-sun16'
tsS'Japanese'
p104
(S'ja_JP.eucJP'
S'iso01'
S'lat0-16'
tsS'Swedish (Finland)'
p105
(S'sv_FI@euro'
S'iso15'
S'lat0-sun16'
tsS'Arabic (Saudi Arabia)'
p106
(S'ar_SA'
S'iso06'
S'LatArCyrHeb-16'
tsS'Spanish (Dominican Republic)'
p107
(S'es_DO'
S'iso01'
S'lat0-sun16'
tsS'French (Canada)'
p108
(S'fr_CA'
S'iso01'
S'lat0-sun16'
tsS'English (Canada)'
p109
(S'en_CA'
S'iso01'
S'lat0-sun16'
tsS'German (Germany)'
p110
(S'de_DE@euro'
S'iso15'
S'lat0-sun16'
tsS'Slovenian (Slovenia)'
p111
(S'sl_SI'
S'iso02'
S'lat2-sun16'
tsS'Spanish (Uruguay)'
p112
(S'es_UY'
S'iso01'
S'lat0-sun16'
tsS'German (Switzerland)'
p113
(S'de_CH'
S'iso01'
S'lat0-sun16'
tsS'English (Hong 
Kong)'
p114
(S'en_HK'
S'iso01'
S'lat0-sun16'
tsS'English (Australia)'
p115
(S'en_AU'
S'iso01'
S'lat0-sun16'
tsS'Catalan 
(Spain)'
p116
(S'ca_ES@euro'
S'iso15'
S'lat0-sun16'
tsS'Spanish (Puerto Rico)'
p117
(S'es_PR'
S'iso01'
S'lat0-sun16'
tsS'Turkish'
p118
(S'tr_TR'
S'iso09'
S'lat5-sun16'
tsS'Estonian'
p119
(S'et_EE'
S'iso01'
S'lat0-sun16'
tsS'Arabic (Sudan)'
p120
(S'ar_SD'
S'iso06'
S'LatArCyrHeb-16'
tsS'Icelandic'
p121
(S'is_IS'
S'iso01'
S'lat0-sun16'
tsS'English (Botswana)'
p122
(S'en_BW'
S'iso01'
S'lat0-sun16'
tsS'Manx Gaelic (Britain)'
p123
(S'gv_GB'
S'iso01'
S'lat0-sun16'
tssS'allSupportedLangs'
p124
(lp125
g49
ag82
ag53
ag32
ag98
ag28
ag79
ag29
ag23
ag26
ag51
ag27
ag97
ag106
ag120
ag76
ag102
ag62
ag17
ag96
ag116
ag56
ag61
ag33
ag77
ag55
ag86
ag45
ag115
ag122
ag109
ag44
ag89
ag114
ag100
ag59
ag52
ag85
ag30
ag67
ag92
ag119
ag57
ag83
ag99
ag108
ag34
ag103
ag31
ag58
ag63
ag81
ag110
ag94
ag113
ag39
ag35
ag66
ag101
ag121
ag54
ag78
ag19
ag80
ag104
ag36
ag73
ag25
ag123
ag50
ag91
ag71
ag69
ag48
ag64
ag90
ag47
ag46
ag72
ag111
ag18
ag60
ag75
ag95
ag43
ag107
ag40
ag70
ag24
ag42
ag38
ag93
ag87
ag65
ag41
ag117
ag74
ag68
ag112
ag88
ag105
ag84
ag118
ag37
asS'info'
p126
(dp127
S'SYSFONT'
p128
g22
sS'SUPPORTED'
p129
S'it_IT@euro:it_IT:it'
p130
sS'SYSFONTACM'
p131
g21
sS'LANG'
p132
g20
ssS'supported'
p133
(lp134
g19
asS'default'
p135
g19
sbsS'instClass'
p136
(icustom
InstallClass
(dp137
S'rootPasswordCrypted'
p138
I0
sS'raidList'
p139
(lsS'nameserver'
p140
S''
sS'x'
NsS'rootPassword'
p141
NsS'makeBootdisk'
p142
I0
sS'installType'
p143
NsS'postScript'
p144
NsS'earlySwapOn'
p145
I0
sS'networkDevice'
p146
NsS'fstab'
p147
(lsS'clearText'
p148
NsS'lilo'
p149
(S'mbr'
p150
I1
S''
tsg13
NsS'name'
p151
S''
sS'postInChroot'
p152
I0
sS'pixmap'
p153
S''
sS'partitions'
p154
(lp155
(S'/boot'
p156
(I48
I-1
I0
t(S''
I-1
I0
t(I0
I0
tNta(S'/'
(I700
I-1
I1
t(S''
I-1
I0
t(I0
I0
tNta(S'swap'
p157
(I96
I192
I1
t(S''
I-1
I0
t(I0
I0
tNtasS'clearType'
p158
S'wkst'
p159
sS'gateway'
p160
S''
sS'mouse'
p161
NsS'packages'
p162
NsS'timezone'
p163
NsS'zeroMbr'
p164
I0
sS'keyboard'
p165
NsS'groups'
p166
NsS'bootProto'
p167
NsS'netmask'
p168
S''
sS'langdefault'
p169
NsS'skipSteps'
p170
(dsS'auth'
p171
(I1
I1
I0
S''
I0
S''
I0
I0
S''
S''
I0
S''
S''
S''
I0
S''
S''
tsS'hostname'
p172
NsS'langsupported'
p173
NsS'showgroups'
p174
NsS'ip'
p175
S''
sS'firewall'
p176
(I-1
I1
(lp177
S''
I0
I0
I0
I0
I0
I0
tsS'defaultRunlevel'
p178
NsS'desktop'
p179
S''
sS'clearPartText'
p180
S'Automatic partitioning will erase any 
preexisting Linux installations on your system.'
p181
sS'clearParts'
p182
I2
sbsS'bdstate'
p183
S''
sS'extraModules'
p184
(lp185
sS'skipLilo'
p186
I0
sS'rootpassword'
p187
NsS'fdDevice'
p188
S'fd0'
p189
sS'installSystem'
p190
I1
sS'comps'
p191
NsS'verifiedState'
p192
Nsg171
(itodo
Authentication
(dp193
S'useNIS'
p194
I0
sS'nisServer'
p195
S''
sS'useLdap'
p196
I0
sS'krb5Kdc'
p197
S''
sS'ldapTLS'
p198
I0
sS'useHesiod'
p199
I0
sS'ldapServer'
p200
S''
sS'nisDomain'
p201
S''
sS'krb5Realm'
p202
S''
sS'useLdapauth'
p203
I0
sS'hesiodRhs'
p204
S''
sS'useShadow'
p205
I1
sS'nisuseBroadcast'
p206
I0
sS'useKrb5'
p207
I0
sS'useMD5'
p208
I1
sS'ldapBasedn'
p209
S''
sS'krb5Admin'
p210
S''
sS'hesiodLhs'
p211
S''
sS'hesiodDlhs'
p212
S''
sbsS'users'
p213
NsS'hdList'
p214
NsS'dhcpState'
p215
S''
sS'method'
p216
(iimage
CdromInstallMethod
p217
(dp218
g4

<failed>





How Reproducible:

Every time I boot the computer from that cd.

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Matt Wilson 2001-07-10 15:26:27 EDT
try booting with "linux ide=nodma".  If this fixes the problem run the following
after you install your system and add the info here.

for I in /proc/ide/hd*; do echo $I; cat $I/model; done

Comment 2 Marco Tului 2001-07-11 16:20:59 EDT
I've tried to do what you've told me... and... it runs!
After I've booted from the cd, I wrote "linux ide=nodma", and the installer
succesfully started! Thank you very much! :-)

Now I'm using my new RedHat 7.1 (it's very nice!), and I'm connected to internet
via adsl (with the RedHat 6.2 I wasn't able to activate my adsl internet
connection -but maybe it wasn't for the RedHat 6.2, but for me... :-) -)

But... excuse me, I'm a newbie... what means what you've told me later? I have
to digit, at a shell promt, exactly this command: "for I in /proc/ide/hd*; do
echo $I; cat $I/model; done" ?
Comment 3 Matt Wilson 2001-07-13 02:26:36 EDT
That's correct, please type in that command and send us the output.
Comment 4 Marco Tului 2001-07-14 00:47:06 EDT
I've typed what you've writed, and this is the output:

/proc/ide/hda
Maxtor 82100A4
/proc/ide/hdb
ST38410A
/proc/ide/hdc
LG CD-RW CED-8042B
/proc/ide/hdd
CRD-8400B

But... before, some times ago, I've installed a RedHat 6.1 (and also, later, a
6.2 one) on the same computer I'm using now, and it runned without any problem!
Why do you want blacklist my CDROM? :-)
Comment 5 Arjan van de Ven 2001-07-14 03:30:57 EDT
RHL71 is the first version that enabled (Ultra)DMA on devices that in the 
"device query" report that they support this. This increases speed a lot, esp 
for harddrives and newer cdrom drives, however there's a small number of 
(usually older) devices that claim to support DMA, but once the kernel starts 
using it, totally get confused because they don't actually support it.

There is a list of such devices, and if a device is on that list (yours will be 
added), the kernel will not try DMA on it. That's the "DMA Blacklist" :)
Comment 6 Marco Tului 2001-07-14 07:45:33 EDT
Thank you for have helped me, and for this information you gave me.

And... I hope I was useful to you. :-)


Goodbye. :-)


p.s.: I'm sorry for my bad English... I'll study better soon. :-)
Comment 7 Arjan van de Ven 2001-07-18 04:20:03 EDT
Ok one last question: which of the drives was the cd in when this failed?
The CDRW or the normal cdrom drive ?
Comment 8 Marco Tului 2001-07-18 15:53:23 EDT
Oh, I'm sorry if I missed to tell you before: it was the CDRW, from which it's
possible to boot the computer.

Thank you, and goodbye. :-)

Note You need to log in before you can comment on or make changes to this bug.