Bug 484659 - WEB TRACEBACK email talking about cobbler after Satellite installation
WEB TRACEBACK email talking about cobbler after Satellite installation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
urgent Severity high
: ---
: ---
Assigned To: Justin Sherrill
Steve Salevan
:
: 483038 490866 (view as bug list)
Depends On:
Blocks: 457075 486216
  Show dependency treegraph
 
Reported: 2009-02-09 05:53 EST by Jan Pazdziora
Modified: 2009-09-10 14:14 EDT (History)
8 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:14:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhn_taskomatic_daemon.log (3.94 KB, text/plain)
2009-02-09 05:54 EST, Jan Pazdziora
no flags Details
catalina.out (3.88 KB, text/plain)
2009-02-09 05:54 EST, Jan Pazdziora
no flags Details
cobbler.log (575 bytes, text/plain)
2009-02-09 05:55 EST, Jan Pazdziora
no flags Details
WEB TRACEBACK email (3.13 KB, application/octet-stream)
2009-03-16 15:04 EDT, Jan Hutař
no flags Details
cobbler-setup Traceback (1.47 KB, text/plain)
2009-03-16 15:10 EDT, Jan Hutař
no flags Details

  None (edit)
Description Jan Pazdziora 2009-02-09 05:53:04 EST
Description of problem:

I've installed Satellite-5.3.0-RHEL5-re20090206.1 on i386. I did not yet go to the WebUI to create the first (admin) user.

Yet, I received email

  From: RHN Satellite <dev-null@redhat.com>
  To: jpazdziora@redhat.com
  Subject: WEB TRACEBACK from vmware139.englab.brq.redhat.com
  Date: Fri, 6 Feb 2009 15:49:06 +0100

  The following is a list of errors gathered while Spacewalk attempts to
  syncronize kickstart distributions from Spacewalk to Cobbler.  These
  errors must be corrected for the distributions to be available for
  kickstarting systems kickstart distributions failed to sync from
  Spacewalk to Cobbler:

  Please check:

  /var/log/rhn/rhn_taskomatic_daemon.log and
  /var/log/tomcat5/catalina.out
  /var/log/cobbler/cobbler.log

  for more detailed errors.  If you don't resolve the errors the kickstart
  tree will not be usable for kickstarting.

Version-Release number of selected component (if applicable):

Compose Satellite-5.3.0-RHEL5-re20090206.1
# rpm -q spacewalk-taskomatic tomcat5 cobbler
spacewalk-taskomatic-0.5.10-1.el5sat
tomcat5-5.5.23-0jpp.7.el5_2.1
cobbler-1.4.0-2.el5

How reproducible:

Observed once.

Steps to Reproduce:
1. Run ./install.pl --disconnected --run-updater
2. After installation, do nothing.
3. Check your email.
  
Actual results:

Received confusing email.

Expected results:

No confusing email.

Additional info:

# ls -la /var/log/rhn/rhn-installation.log
-rw-r--r-- 1 root root 46696 Feb  6 15:47 /var/log/rhn/rhn-installation.log

Date: Fri, 6 Feb 2009 15:49:06 +0100

So that email was sent cca two minutes after the installation finished.
Comment 1 Jan Pazdziora 2009-02-09 05:54:28 EST
Created attachment 331297 [details]
rhn_taskomatic_daemon.log
Comment 2 Jan Pazdziora 2009-02-09 05:54:49 EST
Created attachment 331298 [details]
catalina.out
Comment 3 Jan Pazdziora 2009-02-09 05:55:06 EST
Created attachment 331299 [details]
cobbler.log
Comment 4 Jan Hutař 2009-03-16 15:04:02 EDT
Created attachment 335398 [details]
WEB TRACEBACK email

I have installed Satellite-5.3.0-RHEL5-re20090313.0 and before and after I have created first admin user, I'm getting this email repeatedly (+- one email per minute).
Comment 5 Jan Hutař 2009-03-16 15:10:23 EDT
Created attachment 335400 [details]
cobbler-setup Traceback

When I try a warkaround suggested in bug 483862 comment #3, I'm getting this traceback. I'm using PyYAML-3.06-1.el5 from EPEL.
Comment 6 Preethi Thomas 2009-04-02 11:44:26 EDT
*** Bug 483038 has been marked as a duplicate of this bug. ***
Comment 7 wes hayutin 2009-04-02 12:47:15 EDT
recreated in Satellite-5.3.0-RHEL4-re20090401.0-i386-embedded-oracle.iso

com.redhat.rhn.manager.kickstart.cobbler.NoCobblerTokenException: We errored out trying to login.
        at com.redhat.rhn.manager.kickstart.cobbler.CobblerLoginCommand.login(CobblerLoginCommand.java:57)
        at com.redhat.rhn.frontend.integration.IntegrationService.authorize(IntegrationService.java:113)
        at com.redhat.rhn.frontend.integration.IntegrationService.getAuthToken(IntegrationService.java:66)
        at com.redhat.rhn.manager.kickstart.cobbler.CobblerXMLRPCHelper.getConnection(CobblerXMLRPCHelper.java:95)
        at com.redhat.rhn.taskomatic.task.KickstartFileSyncTask.execute(KickstartFileSyncTask.java:66)
        at com.redhat.rhn.taskomatic.task.SingleThreadedTestableTask.execute(SingleThreadedTestableTask.java:54)
        at org.quartz.core.JobRunShell.run(JobRunShell.java:203)
        at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:520)
Caused by: redstone.xmlrpc.XmlRpcFault: cobbler.cexceptions.CX:'login failed: taskomatic_user'
        at redstone.xmlrpc.XmlRpcClient.handleResponse(XmlRpcClient.java:443)
        at redstone.xmlrpc.XmlRpcClient.endCall(XmlRpcClient.java:376)
        at redstone.xmlrpc.XmlRpcClient.invoke(XmlRpcClient.java:165)
        at com.redhat.rhn.manager.kickstart.cobbler.CobblerXMLRPCHelper.invokeMethod(CobblerXMLRPCHelper.java:69)
        at com.redhat.rhn.manager.kickstart.cobbler.CobblerLoginCommand.login(CobblerLoginCommand.java:52)
        ... 7 more
Comment 8 Justin Sherrill 2009-04-03 12:16:07 EDT
So i've fixed an issue with syncing to cobbler after a sat-sync in commit
e796a58.  I haven't been able to reproduce the authorization issue.  But i will
try again.
Comment 9 Justin Sherrill 2009-04-03 12:16:19 EDT
*** Bug 490866 has been marked as a duplicate of this bug. ***
Comment 10 Justin Sherrill 2009-04-03 16:18:26 EDT
so basically the problem was that during the restart ('rhn-satellite restart') taskomatic would come up before tomcat (even though taskomatic was the last thing started).   As soon as taskomatic is up, it tries to loginto cobbler, which requires tomcat to be up.


I fixed the issue by requiring tomcat to be up before taskomatic starts.  Taskomatic will try to make an xmlrpc call to "http://localhost/rpc/api" every 4 seconds until it gets a valid response before continuing to start.

6fdefd2
Comment 11 Jan Pazdziora 2009-04-05 13:38:57 EDT
I wonder if maybe we could do something about tomcat. Currently, the service tomcat5 start returns with OK even if the tomcat is in fact not yet ready. Maybe if the tomcat5 only returned once it indeed was ready to serve the incoming requests, this workaround would not be needed.
Comment 12 Steve Salevan 2009-04-23 17:45:16 EDT
After installing and later restarting a 4/22 build 530 Satellite, I was unable to cause one of the reported tracebacks to occur.  As it appears that this issue is resolved, I'm moving it to VERIFIED.
Comment 13 Gayathri Swaminathan 2009-07-30 00:34:33 EDT
OS version: Red Hat Enterprise Linux Server release 5.3 (Tikanga)
Spacewalk version: spacewalk-0.5.4-1.el5 along with Oracle XE 

<email content>
java.lang.RuntimeException: java.lang.reflect.InvocationTargetException
        at com.redhat.rhn.common.util.MethodUtil.callNewMethod(MethodUtil.java:276)
        at com.redhat.rhn.common.util.MethodUtil.getClassFromConfig(MethodUtil.java:235)
        at com.redhat.rhn.manager.kickstart.cobbler.CobblerXMLRPCHelper.getCobblerUrl(CobblerXMLRPCHelper.java:100)
        at com.redhat.rhn.manager.kickstart.cobbler.CobblerXMLRPCHelper.<init>(CobblerXMLRPCHelper.java:51)
        at sun.reflect.GeneratedConstructorAccessor24.newInstance(Unknown Source)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
        at java.lang.Class.newInstance0(Class.java:372)
        at java.lang.Class.newInstance(Class.java:325)
        at com.redhat.rhn.common.util.MethodUtil.callNewMethod(MethodUtil.java:261)
        at com.redhat.rhn.common.util.MethodUtil.getClassFromConfig(MethodUtil.java:235)
        at com.redhat.rhn.manager.kickstart.cobbler.CobblerCommand.<init>(CobblerCommand.java:77)
        at com.redhat.rhn.manager.kickstart.cobbler.CobblerDistroSyncCommand.<init>(CobblerDistroSyncCommand.java:49)
        at com.redhat.rhn.taskomatic.task.CobblerSyncTask.execute(CobblerSyncTask.java:83)
        at com.redhat.rhn.taskomatic.task.SingleThreadedTestableTask.execute(SingleThreadedTestableTask.java:54)
        at org.quartz.core.JobRunShell.run(JobRunShell.java:203)
        at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:520)
Caused by: java.lang.reflect.InvocationTargetException
        at sun.reflect.GeneratedConstructorAccessor25.newInstance(Unknown Source)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
        at com.redhat.rhn.common.util.MethodUtil.callNewMethod(MethodUtil.java:268)
        ... 16 more
Caused by: org.cobbler.XmlRpcException: redstone.xmlrpc.XmlRpcFault: exceptions.IOError:[Errno 9] Bad file descriptor
        at org.cobbler.CobblerConnection.adjustUrl(CobblerConnection.java:210)
        at org.cobbler.CobblerConnection.<init>(CobblerConnection.java:58)
        ... 20 more
Caused by: redstone.xmlrpc.XmlRpcFault: exceptions.IOError:[Errno 9] Bad file descriptor
        at redstone.xmlrpc.XmlRpcClient.handleResponse(XmlRpcClient.java:443)
        at redstone.xmlrpc.XmlRpcClient.endCall(XmlRpcClient.java:376)
        at redstone.xmlrpc.XmlRpcClient.invoke(XmlRpcClient.java:165)
        at org.cobbler.CobblerConnection.adjustUrl(CobblerConnection.java:197)
        ... 21 more

</email content>

Verified 
- /etc/rhn/rhn.conf configuration settings
- connectivity to cobbler server (localhost in this case)
Comment 14 Mike McCune 2009-07-31 12:26:18 EDT
Gayathri Swaminathan,

Can you make sure you have the latest cobbler RPM?
Comment 15 Gayathri Swaminathan 2009-07-31 17:57:39 EDT
Mike, 

Have cobbler-1.6.6-1.el5 installed.
Comment 16 Tomas Lestach 2009-09-08 07:26:37 EDT
Receiving no traceback e-mails after installation of Sat 5.3 GA.

Gayathri, if you still have your problem, please, open another BZ.

Stage validated -> RELEASE_PENDING
Comment 17 Brandon Perkins 2009-09-10 14:14:36 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.