Bug 484803 - configure scripts contain broken AC_ERLANG_SUBST_ROOT_DIR code
configure scripts contain broken AC_ERLANG_SUBST_ROOT_DIR code
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: autoconf (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Stepan Kasal
Fedora Extras Quality Assurance
:
: 523433 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-09 18:48 EST by Hans Ulrich Niedermann
Modified: 2009-11-02 09:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-02 09:39:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
autoconf code fix, directly from upstream (2.64 KB, patch)
2009-02-23 12:09 EST, Hans Ulrich Niedermann
no flags Details | Diff
autoconf/F-10/autoconf.spec patch including the fix (1.48 KB, patch)
2009-02-23 12:10 EST, Hans Ulrich Niedermann
no flags Details | Diff

  None (edit)
Description Hans Ulrich Niedermann 2009-02-09 18:48:57 EST
Description of problem:

  configure scripts generated by autoconf 2.63 fail when
  running the broken AC_ERLANG_SUBST_ROOT_DIR code.

  This is caused by an unexpanded instance of AS_ECHO having
  made its way into the code actually executed by /bin/sh.

  Upstream has fixed this issue post-2.63.

Version-Release number of selected component (if applicable):

  autoconf-2.63-1.fc10.noarch

How reproducible:

  100%

Steps to Reproduce:
1. mkdir test && cd test
2. cat>configure.ac<<EOF
AC_INIT([foo], [0.1], [foo@bar], [f])
AC_ERLANG_NEED_ERLC
AC_ERLANG_NEED_ERL
AC_ERLANG_SUBST_ROOT_DIR
AC_ERLANG_SUBST_LIB_DIR
AC_OUTPUT
EOF
3. rm -rf autom4te.cache && autoreconf -vis . && ./configure
  
Actual results:

  [...]
  checking for Erlang/OTP root directory... configure: error: in `/tmp/test':
  configure: error: test Erlang program execution failed
  See `config.log' for more details.

Expected results:

  [...]
  checking for Erlang/OTP library base directory... /usr/lib/erlang/lib
  configure: creating ./config.status

Additional info:

  Upstream fix: http://git.savannah.gnu.org/gitweb/?p=autoconf.git;a=commitdiff;h=20c24928abd703a96ffc79b8ff9e5e215303a141
Comment 1 Hans Ulrich Niedermann 2009-02-23 12:09:22 EST
Created attachment 332945 [details]
autoconf code fix, directly from upstream
Comment 2 Hans Ulrich Niedermann 2009-02-23 12:10:21 EST
Created attachment 332946 [details]
autoconf/F-10/autoconf.spec patch including the fix
Comment 3 Hans Ulrich Niedermann 2009-07-12 06:04:43 EDT
Confirmed in autoconf-2.63-2.fc11.noarch.
Comment 4 Stepan Kasal 2009-11-02 09:39:10 EST
Fixed in autoconf-2.64 in dist-f13; that will appear in rawhide as soon as it
detaches from Fedora 12.
Comment 5 Stepan Kasal 2009-11-02 09:39:32 EST
*** Bug 523433 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.