Bug 484810 - x86_64 update of elfutils fails with "ERROR with rpm_check_debug vs depsolve:"
x86_64 update of elfutils fails with "ERROR with rpm_check_debug vs depsolve:"
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: releng (Show other bugs)
5.2
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Daniel Mach
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-09 19:35 EST by Dale Bewley
Modified: 2011-01-05 03:34 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-05 03:34:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dale Bewley 2009-02-09 19:35:47 EST
Description of problem:
Yum update of elfutils fails with "ERROR with rpm_check_debug vs depsolve:"

Version-Release number of selected component (if applicable):
0.137-3.el5

How reproducible:
Always

Steps to Reproduce:
1. yum -y update elfutils
  
Actual results:
[root@hostname ~]# yum update elfutils
Loaded plugins: rhnplugin
rhel-x86_64-server-5      100% |=========================| 1.3 kB    00:00
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package elfutils.x86_64 0:0.137-3.el5 set to be updated
--> Processing Dependency: elfutils-libs-x86_64 = 0.137-3.el5 for package: elfutils
--> Processing Dependency: elfutils-libelf-x86_64 = 0.137-3.el5 for package: elfutils
--> Processing Dependency: libelf.so.1(ELFUTILS_1.4)(64bit) for package: elfutils
--> Processing Dependency: libelf.so.1(ELFUTILS_1.3)(64bit) for package: elfutils
--> Processing Dependency: libdw.so.1(ELFUTILS_0.130)(64bit) for package: elfutils
--> Processing Dependency: libdw.so.1(ELFUTILS_0.127)(64bit) for package: elfutils
--> Processing Dependency: libdw.so.1(ELFUTILS_0.126)(64bit) for package: elfutils
--> Processing Dependency: libasm.so.1(ELFUTILS_1.0)(64bit) for package: elfutils
--> Processing Dependency: libasm.so.1()(64bit) for package: elfutils
--> Running transaction check
---> Package elfutils-libelf.x86_64 0:0.137-3.el5 set to be updated
---> Package elfutils-libelf.i386 0:0.137-3.el5 set to be updated
---> Package elfutils-libs.x86_64 0:0.137-3.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================================================================================================
 Package                                      Arch                                Version                                   Repository                                         Size
====================================================================================================================================================================================
Updating:
 elfutils                                     x86_64                              0.137-3.el5                               rhel-x86_64-server-5                              216 k
 elfutils-libelf                              x86_64                              0.137-3.el5                               rhel-x86_64-server-5                               53 k
 elfutils-libelf                              i386                                0.137-3.el5                               rhel-x86_64-server-5                               58 k
 elfutils-libs                                x86_64                              0.137-3.el5                               rhel-x86_64-server-5                              183 k

Transaction Summary
====================================================================================================================================================================================
Install      0 Package(s)
Update       4 Package(s)
Remove       0 Package(s)

Total size: 510 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
elfutils-libelf is needed by (installed) elfutils
elfutils-libelf is needed by (installed) elfutils
Complete!
(1, ['Please report this error in bugzilla'])

Expected results:
A clean update

Additional info:
[root@hostname ~]# uname -a
Linux hostname.dom.ain 2.6.18-92.1.10.el5 #1 SMP Wed Jul 23 03:56:11 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux

[root@hostname ~]# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 5.2 (Tikanga)

[root@hostname ~]# rpm -q --qf "%{name}-%{version}-%{release}.%{arch}\n" elfutils
elfutils-0.97.1-5.i386
elfutils-0.125-3.el5.x86_64
Comment 1 Roland McGrath 2009-02-10 15:38:46 EST
This is a distro or yum issue, not an elfutils issue.

You have the RHEL4 elfutils.i386 installed alongside the RHEL5 elfutils.x86_64.
I don't know how you managed that.  Yum is trying to update just the x86_64 one.
If you update elfutils.i386 as well, you should be fine.
Comment 2 Daniel Mach 2011-01-05 03:34:25 EST
Agreed with comment#1.
This is not a bug in RHEL5, closing.

Note You need to log in before you can comment on or make changes to this bug.