Bug 484849 - uuid : expensive superfluous file dependencies
uuid : expensive superfluous file dependencies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: uuid (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-10 05:33 EST by Michael Schwendt
Modified: 2009-05-07 11:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-04 14:11:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2009-02-10 05:33:10 EST
uuid-devel really ought to "Requires: pkgconfig"
instead of depending on %_libdir/pkgconfig. The latter requires
package resolvers to download and parse the huge filelists instead
of just the primary metadata.

$ rpm -q uuid-devel
uuid-devel-1.6.1-3.fc9.i386

It does a similar thing in the -php and -pgsql subpackages.
Inflation of file dependencies will make dependency resolving
in Fedora slower and slower until we are forced to fight such
dependencies with strict guidelines. Please avoid them.

If you have strong doubts that a needed directory will stay in
the same package, add a safety-check to your %prep script.
Comment 1 Michael Schwendt 2009-04-25 08:18:41 EDT
*ping*
Comment 2 Michael Schwendt 2009-05-04 14:11:46 EDT
Fixed committed - in F12 devel tree only.
Comment 3 Michael Schwendt 2009-05-07 11:36:14 EDT
https://www.redhat.com/archives/fedora-devel-list/2009-May/msg00328.html

"Requires: %_libdir/pkgconfig" doesn't work, since it's a hidden broken dep. For example, pkgconfig.i386 is not made available in the x86_64 repo, so nothing provides /usr/lib/pkgconfig, and you don't get pkgconfig.i386 with a dependency on the path. It just seemed to work because other -devel packages included and provided %_libdir/pkgconfig because of packaging bugs. Using "Requires: pkgconfig%{_isa}" was base on the assumption that pkgconfig is multilib'ed, but actually the 32-bit pkgconfig is not available on 64-bit multi-lib platforms.

Note You need to log in before you can comment on or make changes to this bug.