Bug 484879 - 530 satellite-sync against 520 server should provide some meaningful error message
530 satellite-sync against 520 server should provide some meaningful error me...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Jan Hutař
:
Depends On:
Blocks: 457071
  Show dependency treegraph
 
Reported: 2009-02-10 08:52 EST by Jan Hutař
Modified: 2009-09-10 16:04 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:04:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2009-02-10 08:52:29 EST
Description of problem:
530 satellite-sync against 520 server should provide some meaningful error message.


Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090206.1-x86_64


How reproducible:
always


Steps to Reproduce:
1. # satellite-sync --iss-parent=sputnik-prod.brq.redhat.com -l --ca-cert=$(pwd)/RHN-ORG-TRUSTED-SSL-CERT-sputnik-prod -l --debug=6
or:
1. # satellite-sync --iss-parent=sputnik-prod.brq.redhat.com -l --no-ssl -l --debug=6


Actual results:
# satellite-sync --iss-parent=sputnik-prod.brq.redhat.com -l --ca-cert=$(pwd)/RHN-ORG-TRUSTED-SSL-CERT-sputnik-prod -l --debug=6
14:47:02 Red Hat Network Satellite - live synchronization
14:47:02    url: https://sputnik-prod.brq.redhat.com
14:47:02    debug/output level: 6
14:47:02    +++ Satellite synchronization tool checking in.
14:47:02 
14:47:02 
ERROR: there was a problem synchronizing the information.
       Error message: [('SSL routines', 'SSL3_GET_SERVER_CERTIFICATE', 'certificate verify failed')]

# satellite-sync --iss-parent=sputnik-prod.brq.redhat.com -l --no-ssl -l --debug=6
14:47:04 Red Hat Network Satellite - live synchronization
14:47:04    url: http://sputnik-prod.brq.redhat.com
14:47:04    debug/output level: 6
14:47:04    +++ Satellite synchronization tool checking in.
14:47:04 
14:47:04 
ERROR: there was a problem synchronizing the information.
       Error message: 
Error Message:
    Please run rhn_register (or up2date --register on Red Hat Enterprise Linux 3 or later)
as root on this client
Error Class Code: 9
Error Class Info: Invalid System Credentials.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.


Expected results:
Some error message stating that you have to run this command against the newer satellite.
Comment 1 Clifford Perry 2009-02-10 11:37:40 EST
To me the resolution is for the 530 Satellite to capture the Error class code 9 status - see that the command line option --iss-parent was passed with it and then return back new text (rather than text thrown by the 520 Sat) saying something like:

The Server listed within --iss-parent is not configured for this capability. Please review your configuration before trying again. 



Cliff
Comment 2 Miroslav Suchý 2009-02-27 08:49:55 EST
Hmmm, when I tried it, I got:
[root@vmware139 ~]# satellite-sync --iss-parent=sputnik-prod.brq.redhat.com -l --no-ssl -l
 13:23:25 Red Hat Network Satellite - live synchronization
13:23:25    url: http://sputnik-prod.brq.redhat.com
13:23:25    debug/output level: 1
13:23:26    --- This server is not an entitled satellite.

Which seems to me less or more sane. Please let me know if you really insist on mentioning iss in the error message. If you do not insist on it, please close this BZ.
Comment 3 Miroslav Suchý 2009-02-27 09:38:52 EST
Err my message was different because I have been rhn_registred to sputnik-prod. Yes I can confirm this behaviour. 
But of course, I'm going to fix only the second message. Since the first:

ERROR: there was a problem synchronizing the information.
       Error message: [('SSL routines', 'SSL3_GET_SERVER_CERTIFICATE',
'certificate verify failed')]

Is probably completly valid.
Comment 4 Miroslav Suchý 2009-03-13 11:05:44 EDT
Commited c587ddb52000ea2ec2635bccf6729cdf7f6dc0a2
Fixed in spacewalk-backend-0.5.22-1
Comment 5 Jan Hutař 2009-05-21 08:52:04 EDT
VERIFIED on RHEL5 with 20090507.1:



# satellite-sync --iss-parent=sputnik-prod.brq.redhat.com --no-ssl -l --debug=6
14:26:37 Red Hat Network Satellite - live synchronization
14:26:37    url: http://sputnik-prod.brq.redhat.com
14:26:37    debug/output level: 6
14:26:37    +++ Satellite synchronization tool checking in.
14:26:37 
14:26:37 
ERROR: The Server listed within iss-parent is not configured for ISS 
       capability.
       Please review your configuration before trying again.



# wget -O /root/RHN-ORG-TRUSTED-SSL-CERT-sputnik-stage https://sputnik-stage.brq.redhat.com/pub/RHN-ORG-TRUSTED-SSL-CERT --no-check-certificate
# satellite-sync --iss-parent=sputnik-stage.brq.redhat.com --ca-cert=/root/RHN-ORG-TRUSTED-SSL-CERT-sputnik-stage -l --debug=6
14:49:13 Red Hat Network Satellite - live synchronization
14:49:13    url: https://sputnik-stage.brq.redhat.com
14:49:13    debug/output level: 6
14:49:13    +++ Satellite synchronization tool checking in.
14:49:13 
14:49:13 
ERROR: The Server listed within iss-parent is not configured for ISS 
       capability.
       Please review your configuration before trying again.
Comment 7 Brandon Perkins 2009-09-10 16:04:27 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.