This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 484882 - Bug fix updates fails
Bug fix updates fails
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-10 09:08 EST by NM
Modified: 2014-01-21 18:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 15:32:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description NM 2009-02-10 09:08:45 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.6) Gecko/2009020410 Fedora/3.0.6-1.fc10 Firefox/3.0.6

Recently released postgresql-server bug fix can't resolve dependencies:

postgresql-server = 8.3.5 is needed by package sepostgresql-8.3.5-2.1183.fc10.x86_64 : Success - empty transactio


Reproducible: Always

Steps to Reproduce:
1 yum install postgresql-server.x86_64
2.
3.
Actual Results:  
]# yum install postgresql-server.x86_64
Loaded plugins: protect-packages, protectbase, refresh-packagekit
0 packages excluded due to repository protections
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package postgresql-server.x86_64 0:8.3.6-1.fc10 set to be updated
--> Processing Dependency: postgresql = 8.3.6-1.fc10 for package: postgresql-server
--> Processing Dependency: postgresql-server = 8.3.5-1.fc10 for package: postgresql-plperl
--> Processing Dependency: postgresql-server = 8.3.5-1.fc10 for package: postgresql-test
--> Processing Dependency: postgresql-server = 8.3.5 for package: sepostgresql
--> Running transaction check
--> Processing Dependency: postgresql = 8.3.5-1.fc10 for package: postgresql-docs
---> Package postgresql.x86_64 0:8.3.6-1.fc10 set to be updated
--> Processing Dependency: postgresql-libs = 8.3.6-1.fc10 for package: postgresql
---> Package postgresql-plperl.x86_64 0:8.3.6-1.fc10 set to be updated
--> Processing Dependency: postgresql-server = 8.3.5 for package: sepostgresql
---> Package postgresql-test.x86_64 0:8.3.6-1.fc10 set to be updated
--> Running transaction check
---> Package postgresql-docs.x86_64 0:8.3.6-1.fc10 set to be updated
---> Package postgresql-libs.x86_64 0:8.3.6-1.fc10 set to be updated
--> Processing Dependency: postgresql-server = 8.3.5 for package: sepostgresql
--> Finished Dependency Resolution
sepostgresql-8.3.5-2.1183.fc10.x86_64 from installed has depsolving problems
  --> Missing Dependency: postgresql-server = 8.3.5 is needed by package sepostgresql-8.3.5-2.1183.fc10.x86_64 (installed)
Error: Missing Dependency: postgresql-server = 8.3.5 is needed by package sepostgresql-8.3.5-2.1183.fc10.x86_64 (installed)


Expected Results:  
Should be able to find 8.3.5 version

]# yum  info postgresql-server
Loaded plugins: protect-packages, protectbase, refresh-packagekit
0 packages excluded due to repository protections
Installed Packages
Name       : postgresql-server
Arch       : x86_64
Version    : 8.3.5
Release    : 1.fc10
Size       : 12 M
Repo       : installed
Summary    : The programs needed to create and run a PostgreSQL server
URL        : http://www.postgresql.org/
License    : BSD
Description: The postgresql-server package includes the programs needed to create
           : and run a PostgreSQL server, which will in turn allow you to create
           : and maintain PostgreSQL databases.  PostgreSQL is an advanced
           : Object-Relational database management system (DBMS) that supports
           : almost all SQL constructs (including transactions, subselects and
           : user-defined types and functions). You should install
           : postgresql-server if you want to create and maintain your own
           : PostgreSQL databases and/or your own PostgreSQL server. You also need
           : to install the postgresql package.

Available Packages
Name       : postgresql-server
Arch       : x86_64
Version    : 8.3.6
Release    : 1.fc10
Size       : 4.7 M
Repo       : updates
Summary    : The programs needed to create and run a PostgreSQL server
URL        : http://www.postgresql.org/
License    : BSD
Description: The postgresql-server package includes the programs needed to create
           : and run a PostgreSQL server, which will in turn allow you to create
           : and maintain PostgreSQL databases.  PostgreSQL is an advanced
           : Object-Relational database management system (DBMS) that supports
           : almost all SQL constructs (including transactions, subselects and
           : user-defined types and functions). You should install
           : postgresql-server if you want to create and maintain your own
           : PostgreSQL databases and/or your own PostgreSQL server. You also need
           : to install the postgresql package.
Comment 1 seth vidal 2009-02-10 10:15:45 EST
So it looks like sepostgresql was just rebuilt on the 6th of feb to accomodate the new postgresql 8.3.6. Can you run:

yum clean expire-cache

and try the same command again? This looks like a legit dep error.
Comment 2 NM 2009-02-10 15:41:43 EST
Did not work for me....
]# yum clean expire-cache
Loaded plugins: protect-packages, protectbase, refresh-packagekit
4 metadata files removed
# yum update
Loaded plugins: protect-packages, protectbase, refresh-packagekit
0 packages excluded due to repository protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package postgresql.x86_64 0:8.3.6-1.fc10 set to be updated
---> Package postgresql-docs.x86_64 0:8.3.6-1.fc10 set to be updated
---> Package postgresql-libs.x86_64 0:8.3.6-1.fc10 set to be updated
---> Package postgresql-plperl.x86_64 0:8.3.6-1.fc10 set to be updated
--> Processing Dependency: postgresql-server = 8.3.5 for package: sepostgresql
---> Package postgresql-server.x86_64 0:8.3.6-1.fc10 set to be updated
---> Package postgresql-test.x86_64 0:8.3.6-1.fc10 set to be updated
--> Finished Dependency Resolution
sepostgresql-8.3.5-2.1183.fc10.x86_64 from installed has depsolving problems
  --> Missing Dependency: postgresql-server = 8.3.5 is needed by package sepostgresql-8.3.5-2.1183.fc10.x86_64 (installed)
Error: Missing Dependency: postgresql-server = 8.3.5 is needed by package sepostgresql-8.3.5-2.1183.fc10.x86_64 (installed)

Thanks anyway
Comment 3 seth vidal 2009-02-10 15:46:10 EST
could you run:

yum list sepostgresql

and send the output, please.
Comment 4 NM 2009-02-10 15:57:39 EST
Sure.
# yum list sepostgresql
Loaded plugins: protect-packages, protectbase, refresh-packagekit
0 packages excluded due to repository protections
Installed Packages
sepostgresql.x86_64                                    8.3.5-2.1183.fc10                                    installed

regards
NM
Comment 5 seth vidal 2009-02-16 15:32:06 EST
I'm hopeful that your mirror is synced up now. Please refresh your cache and try this again. Reopen the bug if it persists.

Note You need to log in before you can comment on or make changes to this bug.