Bug 484889 - kernel BUG at fs/namei.c:1183
kernel BUG at fs/namei.c:1183
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.2
i586 Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-10 10:06 EST by Emile Le Roux
Modified: 2012-06-14 16:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 16:06:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emile Le Roux 2009-02-10 10:06:56 EST
Description of problem:
System hang, 
# /var/log/messages
Jan  6 14:58:05 godel kernel: ------------[ cut here ]------------
Jan  6 14:58:05 godel kernel: kernel BUG at fs/namei.c:1183!
Jan  6 14:58:05 godel kernel: invalid operand: 0000 [#1]
Jan  6 14:58:05 godel kernel: SMP
Jan  6 14:58:05 godel kernel: Modules linked in: ppdev joydev vmnet(U) vmblock(U) vmmon(U) mvfs(U) vnode(U) nfsd exportfs parport_pc lp parport nfs lockd nfs_
acl autofs4 sunrpc iptable_filter ip_tables microcode md5 ipv6 dm_mirror button battery ac uhci_hcd ehci_hcd nvidia(U) i2c_core hw_random tg3 floppy ata_piix
ext3 jbd dm_mod mptscsih mptsas mptspi mptscsi mptbase ahci libata sd_mod scsi_mod
Jan  6 14:58:05 godel kernel: CPU:    0
Jan  6 14:58:05 godel kernel: EIP:    0060:[<c0169a3b>]    Tainted: PF     VLI
Jan  6 14:58:05 godel kernel: EFLAGS: 00010293   (2.6.9-55.0.2.ELsmp)
Jan  6 14:58:05 godel kernel: EIP is at vfs_rename+0x49/0x338
Jan  6 14:58:05 godel kernel: eax: e6ef5b94   ebx: ffffffd9   ecx: e5911718   edx: fffffffe
Jan  6 14:58:05 godel kernel: esi: e30f684c   edi: e30f684c   ebp: e71c30e4   esp: dc612ee4
Jan  6 14:58:05 godel kernel: ds: 007b   es: 007b   ss: 0068
Jan  6 14:58:05 godel kernel: Process cleargui (pid: 29515, threadinfo=dc612000 task=f5bee6b0)
Jan  6 14:58:05 godel kernel: Stack: 00000001 ffffffd9 dac2bafc e71c30e4 e1229afc c0169e77 dac2bafc 00000000
Jan  6 14:58:05 godel kernel:        e1229afc c839f000 d769e000 e1229afc f619ed80 bfb45825 00000018 c839f024
Jan  6 14:58:05 godel kernel:        00000010 00000000 00000000 fffffffe dc612f60 00000401 d769e000 c0167d9f
Jan  6 14:58:05 godel kernel: Call Trace:
Jan  6 14:58:05 godel kernel:  [<c0169e77>] sys_rename+0x14d/0x1e0
Jan  6 14:58:05 godel kernel:  [<c0167d9f>] __user_walk+0x4a/0x51
Jan  6 14:58:05 godel kernel:  [<c015a043>] sys_access+0x8f/0x134
Jan  6 14:58:05 godel kernel:  [<c01261ab>] sys_time+0xf/0x58
Jan  6 14:58:05 godel kernel:  [<c02d6093>] syscall_call+0x7/0xb
Jan  6 14:58:05 godel kernel:  [<c02d007b>] unix_stream_sendmsg+0x227/0x33a
Jan  6 14:58:05 godel kernel: Code: 00 00 0f 94 c0 0f b6 c0 89 04 24 31 c0 3b 4a 10 0f 84 fe 02 00 00 85 c9 ba fe ff ff ff 0f 84 dd 00 00 00 8b 45 14 39 78 10
 74 08 <0f> 0b 9f 04 87 ad 2e c0 89 c8 ba 02 00 00 00 e8 fc 5b fd ff 31
Jan  6 14:58:05 godel kernel:  <0>Fatal exception: panic in 5 seconds


Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux ES release 4 (Nahant Update 2)
Linux 2.6.9-55.0.2.ELsmp #1 SMP Tue Jun 12 17:59:08 EDT 2007 i686 i686 i386 GNU/Linux

How reproducible:
random 

Steps to Reproduce:
1. 
2.
3.
  
Actual results:
After reboot, the system is running 

Expected results:


Additional info:
Comment 1 Bryn M. Reeves 2009-05-29 06:58:26 EDT
This looks like a known issue with MVFS - you should contact the vendor responsible for supporting these components in your environment.
Comment 2 Jeremy West 2012-06-14 16:06:02 EDT
This bug is being closed now that RHEL4 has entered a limited maintanence phase.  If you're a customer with ELS entitlements and need to have this fixed, please contact our support team by visiting access.redhat.com

Note You need to log in before you can comment on or make changes to this bug.