Bug 484968 - clogd can seg fault
clogd can seg fault
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cmirror (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Jonathan Earl Brassow
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-10 16:58 EST by Jonathan Earl Brassow
Modified: 2010-01-11 21:09 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:05:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Earl Brassow 2009-02-10 16:58:29 EST
The cluster log server can seg fault.  This means that the kernel can no longer communicate with userspace and get any work done.
Comment 1 Jonathan Earl Brassow 2009-02-10 17:14:37 EST
If a mirror was started and then suspended very shortly after, the list of pent-up requests waiting for a checkpoint would be freed.  If one of those requests was POSTSUSPEND, it would be processed and would also try to free the list of pent-up requests.  Since this action was nested, the outer function would segfault because the list it was processing was free out from under it.

commit c9d6207f212f900f66c9c6990462bae328ede121
Author: Jonathan Brassow <jbrassow@redhat.com>
Date:   Tue Feb 10 16:11:43 2009 -0600
Comment 3 Corey Marthaler 2009-06-11 14:32:20 EDT
I have not seen any seg faults with the latest rpms, marking verified.

2.6.18-150.el5

lvm2-2.02.46-5.el5    BUILT: Sat Jun  6 16:29:23 CDT 2009
lvm2-cluster-2.02.46-5.el5    BUILT: Sat Jun  6 16:28:13 CDT 2009
device-mapper-1.02.32-1.el5    BUILT: Thu May 21 02:18:23 CDT 2009
cmirror-1.1.37-1.el5    BUILT: Tue May  5 11:46:05 CDT 2009
kmod-cmirror-0.1.21-14.el5    BUILT: Thu May 21 08:28:17 CDT 2009
Comment 5 errata-xmlrpc 2009-09-02 07:05:56 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1340.html

Note You need to log in before you can comment on or make changes to this bug.