Bug 484974 - Support for DVDRW is listed when it's not supported
Support for DVDRW is listed when it's not supported
Status: CLOSED NOTABUG
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
5.3
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: YangKun
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-10 17:12 EST by Adam Sheltz
Modified: 2014-03-25 20:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-25 00:28:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Results from HTS finding a supported DVDRW. (1020.38 KB, text/xml)
2009-02-10 17:15 EST, Adam Sheltz
no flags Details
SOS Report (665.32 KB, application/octet-stream)
2009-02-11 10:01 EST, Adam Sheltz
no flags Details

  None (edit)
Description Adam Sheltz 2009-02-10 17:12:27 EST
Description of problem:  HTS 5.3-15 recognizes a DVD/CDRW incorrectly as a DVDRW/DVD/CDRW  

HL-DT-STCD-RW/DVD DRIVE GCC-T20N


Version-Release number of selected component (if applicable):
5.3-15

How reproducible:
Everytime

Steps to Reproduce:
1.  Install hts-5.3-15
2.  hts plan
3.  hts certify
  
Actual results:
hts finds a DVDRW


Expected results:
hts doesn't find DVDRW that isn't there.


Additional info:
See attached.
Comment 1 Adam Sheltz 2009-02-10 17:15:52 EST
Created attachment 331487 [details]
Results from HTS finding a supported DVDRW.
Comment 2 Joseph Kachuck 2009-02-11 09:09:52 EST
From speaking with Adam on this issue. The HTS finds a DVDRW that should be a DVD/CDRW. The test then fails on the DVDRW part.

Adam please also attach a sosreport from the server showing this issue.

Thank You
Joe Kachuck
Comment 3 Adam Sheltz 2009-02-11 10:01:51 EST
Created attachment 331569 [details]
SOS Report
Comment 4 Greg Nichols 2009-02-11 11:12:43 EST
Via the attached results.xml, it appears HAL is reporting that DVDRW is supported:

 storage.cdrom.dvdplusrw = True

and:

 storage.cdrom.dvdrw = True


The error from cdrecord is as follows:

scsidev: '/dev/scd0'
devname: '/dev/scd0'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
cdrecord: Warning: using inofficial libscg transport code version (schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c	1.83 04/05/20 Copyright 1997 J. Schilling').
SCSI buffer size: 64512
cdrecord: Sorry, no CD/DVD-Recorder or unsupported CD/DVD-Recorder found on this target.
Comment 6 Adam Sheltz 2009-02-11 13:20:20 EST
Maybe lshal isn't the best thing to use to determine what tests should be run. 

Case in point would be for every new Processor that is released a vendor will have to open a defect to have that processor added to the processor.can_throttle = true list in order for cpuscaling to be detected properly. 

Regardless of what HAL is reporting my DVD/CDRW drive doesn't support dvdplusdl, dvdplusrwdl, dvdplusrw, or dvdrw.
Comment 7 YangKun 2009-02-12 00:26:40 EST
Hi Adam,

I checked the logs, there're two optical drives in the system:

    o /dev/hda   -->  HL-DT-STCD-RW/DVD DRIVE GCC-T20N
    o /dev/scd0  -->  Virtual CD/DVD

the DVD test ran well with "hda(HL-DT-STCD-RW/DVD DRIVE GCC-T20N)", is this device you are concerning about ?

As for the "scd0(Virtual CD/DVD)", could you please tell me what kind of device it is ? An IBM VIO device ? 

Thanks
-YK
Comment 8 Adam Sheltz 2009-02-19 16:23:47 EST
There is only one physical optical drive on the system.  

/dev/hda is linked to the actual physical optical drive.
/dev/scd0 is linked to several things in /dev/  cdrom, cdrom-sr0, dvd, dvd-sr0, & sr0.

When I put a cd in the system it mounts under hda.

I forcibly un-mount it and try remounting it mapping it to one of the scd0 devices and it doesn't see any media.
Comment 9 YangKun 2009-02-19 22:24:28 EST
(In reply to comment #8)
> There is only one physical optical drive on the system.  
> 
> /dev/hda is linked to the actual physical optical drive.

ok, thanks for confirming this.

> /dev/scd0 is linked to several things in /dev/  cdrom, cdrom-sr0, dvd, dvd-sr0,
> & sr0.

actually I was asking what kind of hardware the "/dev/scd0" is ? Is it a "real" device ?

> 
> When I put a cd in the system it mounts under hda.

based the results, the testing went well with /dev/hda.

> 
> I forcibly un-mount it and try remounting it mapping it to one of the scd0
> devices and it doesn't see any media.

why "forcibly un-mount it and try remounting it mapping it to one of the scd0 devices" ? why testing scd0 ?

Thanks
-YK
Comment 10 Adam Sheltz 2009-02-24 14:08:53 EST
I was trying to determine what it was... that is why I was trying to mount it.

I think we may be seeing the IMM (integrated management module). 
There is a retain tip that hasn't been published yet. 

	EMPTY VIRTUAL USB DRIVES
New IBM System x / BladeCenter RETAIN Tip.




  Record number:        H194772
  Device:               D/T7321
  Model:                M
  Hit count:            UHC00000
  Success count:        USC0000
  Publication code:     PC50
  Tip key:		 
  Date created:         O09/02/24
  Date last altered:    A09/02/24
  Owning B.U.:          USA

  Abstract:  EMPTY VIRTUAL USB DRIVES

SYMPTOM:
                                                                
By default the Integrated Management Module (IMM) presents      
empty virtual drives on its USB interface to the server. These  
devices are part of a composite USB device that includes the    
IMM virtual keyboard and mouse and are used with the IMM remote 
presence functionality.                                         
                                                                
If the USB device representing the virtual drive is reset,      
instead of resetting the entire USB composite device, the drive 
may appear as a new device to Windows operating systems and be  
enumerated as an additional drive and the original virtual      
drive will be inaccessible.                                     

PROBLEM ISOLATION AIDS:
                                                                
- The system may be any of the following IBM servers:           
                                                                
     iDataPlex dx360 M2 Server, Type 7321, any model            
     BladeCenter HS22, Type 7870, any model                     
     System x3550 M2, Type 7946, any model                      
     System x3650 M2, Type 7947, any model                      
                                                                
- This tip is not option specific.                              
                                                                
- This tip is not software specific.                            
                                                                
- The system has the symptom described above.                   

FIX:
                                                                
This behavior will be corrected in a future release if the IMM  
firmware.                                                       
                                                                
The IMM behavior will be changed to not present empty virtual   
drives by default. The virtual drives will only be presented to 
the server when a client is running the IMM remote presence     
function and has mounted and mapped media on the remote client. 
                                                                
The target date for this release is scheduled for Second        
Quarter 2009.                                                   
                                                                
The file will be available from the IBM System x Support web    
site at the following URL:                                      
                                                                
     http://www.ibm.com/systems/support/                        
                                                                
WORKAROUND:                                                     
                                                                
Ignore the 2 empty virtual drives on the server.                
                                                                
If you wish to reset the USB interface to the virtual drives,   
reset the higher level USB composite device that also includes  
the virtual keyboard and mouse. This can be accomplished using  
Windows' Device Manager:                                        
                                                                
1. In Device Manager locate the "Universal Serial Bus           
   controllers" item and expand it.                             
                                                                
2. Locate the "USB Composite Device" whose "Details" property   
   tab indicates "USB\VID_04B3&PID_4012" for the Device         
   Instance ID.                                                 
                                                                
   This is the composite device associated with the virtual     
   drives.                                                      
                                                                
3. Select this USB Composite Device and select the menu action  
   to uninstall it.                                             
                                                                
4. Then to re-enable the composite device, select the           
   "Universal Serial Bus controllers" item and select the menu  
   action to Scan for hardware changes.                         
                                                                
DETAILS:                                                        
                                                                
Resetting the higher level USB composite device is the proper   
way to reset because it causes the USB bus between the server   
and the IMM to be reset and all of the endpoints get            
re-enumerated from.                                             
                                                                
TRADEMARKS:                                                     
                                                                
BladeCenter, System x, System x are trademarks of International 
Business Machines Corporation in the United States, other       
countries, or both.                                             
                                                                
Microsoft, Windows, Windows NT, and the Windows logo are        
trademarks of Microsoft Corporation in the United States, other 
countries, or both.                                             
                                                                
Other company, product, or service names may be trademarks or   
service marks of others.
Comment 11 YangKun 2009-02-25 00:28:22 EST
Hi Adam,

Thanks for providing these info. 

Looks like the "scd0" is indeed a virtual device from IMM. I believe it has no business with the local optical drive(/dev/hda):

  >> The virtual drives will only be presented to 
  >> the server when a client is running the IMM remote presence     
  >> function and has mounted and mapped media on the remote client. 


Back to the original issue you reported in this bug. I saw the DVD test worked well with the "/dev/hda"(HL-DT-STCD-RW/DVD DRIVE GCC-T20N). So I'm going to close this bug as NOTABUG now.

-YK

Note You need to log in before you can comment on or make changes to this bug.