Bug 485024 - Broken translation for German
Broken translation for German
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lrzsz (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-11 03:33 EST by Dwayne Bailey
Modified: 2009-02-11 08:32 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-11 08:32:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Changes to .spec to delete all po/*.gmo before building (442 bytes, patch)
2009-02-11 03:35 EST, Dwayne Bailey
no flags Details | Diff

  None (edit)
Description Dwayne Bailey 2009-02-11 03:33:58 EST
Description of problem:
The German .mo file installed by lrzsz is broken.  This is due to the fact that source tarball includes a broken de.gmo, newer ones are not created due to Makefile rules.

msgunfmt /usr/share/locale/de/LC_MESSAGES/lrzsz.mo

Observer all the errors about multibyte encoding errors

Version-Release number of selected component (if applicable):
0.12.20

How reproducible:
Always

Steps to Reproduce:
1. in tarball
2. cd po/
3. ls -l de.gmo
4. do all building stuff
5. ls -l de.gmo - unchanged
6. msgfmt de.po
7. ls -l messages.mo - notice different sizes
8. rm po/de.gmo
9. make
10. ls -l po/de.gmo - notice that its updated and matches messages.mo size
  
Actual results:
Nothing built

Expected results:
We build correctly

Additional info:
I'll attach idea of a patch
Comment 1 Dwayne Bailey 2009-02-11 03:35:38 EST
Created attachment 331531 [details]
Changes to .spec to delete all po/*.gmo before building

I did think about patching the source, but that seemed like overkill.  Instead I simply removed all po/*.gmo from the tarball before we run make
Comment 2 Miroslav Lichvar 2009-02-11 08:32:50 EST
Fixed in lrzsz-0.12.20-25.fc11. Thanks.

Note You need to log in before you can comment on or make changes to this bug.