Bug 485027 - Fedora won't boot with the newest kernel if root is on an lvm volume
Fedora won't boot with the newest kernel if root is on an lvm volume
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-11 03:44 EST by Thomas Schweikle
Modified: 2009-04-08 19:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-08 19:53:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mkinitrd run for the newest kernel. (8.87 KB, text/plain)
2009-02-11 03:50 EST, Thomas Schweikle
no flags Details

  None (edit)
Description Thomas Schweikle 2009-02-11 03:44:30 EST
Description of problem:
Fedora won't boot with the newest kernel if root is on an lvm volume

Version-Release number of selected component (if applicable):
vmlinuz-2.6.29-0.93.rc3.git10.fc11.i586
vmlinuz-2.6.29-0.99.rc4.git1.fc11.i586

How reproducible:
Always.

Steps to Reproduce:
1. Install Fedora 10
2. Upgrade to Fedora 11 alpha
3. Replace the kernel
  
Actual results:
New kernel installed does boot, but then can't find device
"/dev/VolGroup00/LogVol00" and
"/dev/VolGroup00/LogVol01".
The system ist stopped.

Expected results:
Booting and finding "/dev/VolGroup00/LogVol00" and "/dev/VolGroup00/LogVol01". Continuing boot.

Additional info:
It looks to me, as if the modules for lvm2 are within the initrd, but there is never a vgscan done activating VolGroup00. Result since this isn't activated, devices are never created and can't be found by the kernel --- even if the modules are loaded!

I am not shure this being a kernel or some script problem.
Comment 1 Thomas Schweikle 2009-02-11 03:50:44 EST
Created attachment 331533 [details]
mkinitrd run for the newest kernel.

What "mkinitrd -v -f initrd-2.6.29-0.99.rc4.git1.fc11.i586.img 2.6.29-0.99.rc4.git1.fc11.i586" includes into the initrd-image.
Comment 2 Kyle McMartin 2009-02-27 08:56:41 EST
There were some issues with waiting for the lvm devices to show up earlier... Can you try booting with "boot_delay=5"? Is it still an issue?
Comment 3 Thomas Schweikle 2009-03-03 03:28:58 EST
Yes, this does not change anything. Even setting it to 30s does not help. Afaics the problem is, the vgscan command is not issued the time root is expected to be mounted ...
Comment 4 Thomas Schweikle 2009-04-08 19:53:47 EDT
Since the latest upgrades the bug is gone. Seems solved!

Note You need to log in before you can comment on or make changes to this bug.