Bug 485033 - iptables -p ALL --dport not allowed according to man 8 iptables
iptables -p ALL --dport not allowed according to man 8 iptables
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Deployment_Guide (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Jaromir Hradilek
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-11 04:41 EST by Per Sjoholm
Modified: 2011-07-21 12:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 12:10:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Per Sjoholm 2009-02-11 04:41:31 EST
Description of problem:
Faulty syntax in documentation 
http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.2/html/Deployment_Guide/s2-server-nis-ports.html
May also be error in other places
 
or a fault and wrong in man iptables(8)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Follow deployment guide and edit /etc/sysconfig/iptables 
   -A INPUT -p ALL -s! 192.168.0.0/24  --dport 834 -j DROP

2. service iptables restart
3. change -p all to -p tcp or -p udp
4. service iptables restart
5. service  started OK
  
Actual results:
iptables-restore will complain about --dport

Expected results:
service  started OK


Additional info:

This may be a fault somewere

but man 8 iptables 
   -p all = tcp, udp and icmp
multiport
       This  module matches a set of source or destination ports.  Up to 15 ports can be specified.
       A port range (port:port) counts as two ports.  It can only be used in  conjunction  with  -p tcp or -p udp.

       --source-ports [!] port[,port[,port:port...]]
              Match  if  the  source port is one of the given ports.  
              The flag --sports is a convenient alias for this option.

       --destination-ports [!] port[,port[,port:port...]]
              Match if the destination port is one of the given ports.  
              The flag --dports is a convenient alias for this option.

       --ports [!] port[,port[,port:port...]]
              Match  if either the source or destination ports are equal to one of the given ports.
Comment 3 RHEL Product and Program Management 2010-08-09 15:17:21 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 Michael Doyle 2011-03-06 19:42:50 EST
Verified in 45.2.3.4. Assign Static Ports and Use iptables Rules of Red_Hat_Enterprise_Linux-Deployment_Guide-5-en-US-6-40

Note You need to log in before you can comment on or make changes to this bug.