Bug 485041 - german date manpage misses %u
german date manpage misses %u
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: man-pages-de (Show other bugs)
5.3
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Marcela Mašláňová
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-11 05:27 EST by Rainer Traut
Modified: 2009-10-12 04:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-12 04:21:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rainer Traut 2009-02-11 05:27:38 EST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6

The german man page misses the format %u.

With german locale:
       %T     Zeit, 24-Stunden (hh:mm:ss)
       %U     Wochennummer des Jahres mit Sonntag als erstem Tag der Woche (00..53)
       %V     Wochennummer des Jahres mit Montag als erstem Tag der Woche (01..53)
       %w     Tag der Woche (0..6);  0 ist Sonntag

with en_US locale:

       %u     day of week (1..7); 1 is Monday
       %U     week number of year, with Sunday as first day of week (00..53)
       %V     ISO week number, with Monday as first day of week (01..53)
       %w     day of week (0..6); 0 is Sunday       


Reproducible: Always

Steps to Reproduce:
1. export LANG=de_DE
2. man date
3. 
Actual Results:  
With german locale:
       %T     Zeit, 24-Stunden (hh:mm:ss)
       %U     Wochennummer des Jahres mit Sonntag als erstem Tag der Woche (00..53)
       %V     Wochennummer des Jahres mit Montag als erstem Tag der Woche (01..53)
       %w     Tag der Woche (0..6);  0 ist Sonntag

Expected Results:  
%u description

The german man page is missing the %u format string. Problem is, this format is the commonly used german format, with weeks starting on monday.
Comment 1 Ondrej Vasik 2009-02-11 06:06:06 EST
Thanks for report. That manpage is not from coreutils package - coreutils do ship just english manpages and info documentation and string translations for languages. As %u is present in string translation (--help) error is only on side of man-pages-de. As a note: Missing %u description still present in Fedora Rawhide. Reassigning to man-pages-de.
Comment 2 Marcela Mašláňová 2009-02-11 07:13:44 EST
The German pages are out of date for a long time because there are no new releases from upstream project. I strongly suggest using English manual.

This one problem could be fixed but I don't think there will be RHEL update for such a small change.
Comment 3 Rainer Traut 2009-02-11 08:11:12 EST
Sorry I do not understand.
The upstream project is gnu coreutils; looking inside the oldest version of coreutils on their ftp (coreutils-5.0.tar.bz2) I do not see any localized man page inside.
Who has stopped updating localized man pages?
Comment 4 Marcela Mašláňová 2009-02-11 08:17:37 EST
As was told in comment#1 man page isn't part of coreutils but man-pages-de. And those man pages are outdated. The upstream project is located here http://www.infodrom.org/projects/manpages-de/changes.php
Comment 5 Rainer Traut 2009-02-11 08:33:56 EST
Your link seems wrong, the latest release is here
http://www.infodrom.org/projects/manpages-de/news-2006-11-27.php
But this newer version 0.5 has the same bug so it is not relevant to this bug.

I deinstalled man-pages-de and am using now english versions...
Comment 6 Marcela Mašláňová 2009-10-12 04:21:46 EDT
man-pages-de has dead upstream, last release was made 3 years ago -> closing as cantfix

Note You need to log in before you can comment on or make changes to this bug.