Bug 485042 - yum-plugins/rpm-warm-cache.py error
yum-plugins/rpm-warm-cache.py error
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 475936 481102 486527 499117 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-11 05:30 EST by Mustafa Mehmed
Modified: 2014-01-21 18:08 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 11:54:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mustafa Mehmed 2009-02-11 05:30:40 EST
Description of problem:

Pop-up window with the following error displayed:-
Error Type: <type 'exceptions.TypeError'>
Error Value: 'NoneType' object is unsubscriptable
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2302, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2299, in main
    backend.dispatcher(sys.argv[1:])
  File : /usr/lib/python2.5/site-packages/packagekit/backend.py, line 600, in dispatcher
    self.dispatch_command(args[0], args[1:])
  File : /usr/lib/python2.5/site-packages/packagekit/backend.py, line 504, in dispatch_command
    self.get_distro_upgrades()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1656, in get_distro_upgrades
    self._check_init()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1983, in _check_init
    self.yumbase.repos.doSetup()
  File : /usr/lib/python2.5/site-packages/yum/repos.py, line 71, in doSetup
    self.ayum.plugins.run('postreposetup')
  File : /usr/lib/python2.5/site-packages/yum/plugins.py, line 178, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File : /usr/lib/yum-plugins/rpm-warm-cache.py, line 32, in postreposetup_hook
    cmd = commands[0]




Version-Release number of selected component (if applicable):


yum-3.2.21-2.fc10.noarch

How reproducible:

Don't know - ocassional random popups.


Steps to Reproduce:
1.
2.
3.
  
Actual results:

Popup window with error message displayed.


Expected results:

No popups.

Additional info:

Installed a whole heap of yum-plugins today :-

Feb 11 10:31:53 Installed: 1:yum-updatesd-0.9-1.fc9.noarch
Feb 11 10:31:53 Installed: yum-refresh-updatesd-1.1.19-1.fc10.noarch
Feb 11 10:31:56 Installed: yumex-2.0.5-3.fc10.noarch
Feb 11 10:31:56 Installed: yum-filter-data-1.1.19-1.fc10.noarch
Feb 11 10:31:56 Installed: yum-fastestmirror-1.1.19-1.fc10.noarch
Feb 11 10:31:57 Installed: yum-protect-packages-1.1.19-1.fc10.noarch
Feb 11 10:31:57 Installed: yum-keys-1.1.19-1.fc10.noarch
Feb 11 10:31:57 Installed: yum-verify-1.1.19-1.fc10.noarch
Feb 11 10:31:57 Installed: yum-upgrade-helper-1.1.19-1.fc10.noarch
Feb 11 10:31:57 Installed: yum-merge-conf-1.1.19-1.fc10.noarch
Feb 11 10:31:57 Installed: yum-fedorakmod-1.1.19-1.fc10.noarch
Feb 11 10:31:57 Installed: yum-kernel-module-1.1.19-1.fc10.noarch
Feb 11 10:31:57 Installed: yum-rpm-warm-cache-1.1.19-1.fc10.noarch
Feb 11 10:31:58 Installed: yum-updateonboot-1.1.19-1.fc10.noarch
Feb 11 10:31:58 Installed: yum-list-data-1.1.19-1.fc10.noarch
Feb 11 10:31:58 Installed: yum-remove-with-leaves-1.1.19-1.fc10.noarch
Feb 11 10:31:59 Installed: deltarpm-3.4-11.fc10.i386
Feb 11 10:31:59 Installed: yum-presto-0.4.5-1.fc9.noarch


from /var/log/secure
secure:Feb 11 10:32:08 localhost userhelper[13171]: pam_unix(yumex:auth): conversation failed
secure:Feb 11 10:32:08 localhost userhelper[13171]: pam_unix(yumex:auth): auth could not identify password for [root]
secure:Feb 11 10:32:49 localhost userhelper[13190]: pam_timestamp(yumex:session): updated timestamp file `/var/run/sudo/mehmed/unknown:root'
secure:Feb 11 10:32:49 localhost userhelper[13197]: running '/usr/share/yumex/yumex ' with root privileges on behalf of 'mehmed'
Comment 1 Mustafa Mehmed 2009-02-11 22:13:16 EST
Removed yum-rpm-warm-cache-1.1.19-1.fc10.noarch

rpm -e yum-rpm-warm-cache

and the error has gone
Comment 2 seth vidal 2009-02-16 11:54:18 EST
this problem is fixed in upstream git - but not yet in a released yum-utils.
Comment 3 seth vidal 2009-02-27 14:33:19 EST
*** Bug 486527 has been marked as a duplicate of this bug. ***
Comment 4 seth vidal 2009-02-28 08:55:26 EST
*** Bug 481102 has been marked as a duplicate of this bug. ***
Comment 5 seth vidal 2009-03-03 16:46:05 EST
*** Bug 475936 has been marked as a duplicate of this bug. ***
Comment 6 Michal Schmidt 2009-05-15 08:54:57 EDT
*** Bug 499117 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.