Bug 485043 - Using SSH to "yum update" cause system corrupt
Using SSH to "yum update" cause system corrupt
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-11 05:37 EST by iusers
Modified: 2014-01-21 18:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-12 08:04:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description iusers 2009-02-11 05:37:19 EST
Using SSH to "yum update" cause system corrupt

Description of problem:
When I update Fedora 5 to 8 (using internet), I install the fedora-release package, then run "yum update".

The update success, then I restart the machine and run "yum update" again. I use SSH to login as root and run the update.

It hangs here:

 Cleanup   : openssh-server               ##################### [478/705]

When I restart the machine again, the system corrupt.

Version-Release number of selected component (if applicable):
Fedora 8

How reproducible:
Use SSH to run "yum update" to update openssh-server.
  
Actual results:
System hangs and corrupt.

Expected results:
openssh-server updated.
Comment 1 iusers 2009-02-11 05:38:41 EST
>>Fedora 5 to 8
Should be from Fedora 5 to Fedora 9
Comment 2 seth vidal 2009-02-12 08:04:55 EST
So a couple of things
1. upgrading from fedora 5 to fedora 9 is a big jump  - lots of things can change in painful ways
2. What happened was your ssh session went away b/c of the new openssh-server that was installed and yum could no longer communicate.

To prevent this for large updates like this you can run yum inside a screen session - look up the screen man page.

You may also want to look at the program package-cleanup - in yum-utils to see about correcting some of the left over packages.
Comment 3 iusers 2009-02-12 20:01:01 EST
But I don't think it's the problem of upgrading from Fedora 5 to 9.

>> The update success, then I restart the machine and run "yum update" again. 
>> I use SSH to login as root and run the update.

Because, the first "yum update" is success, I am already in Fedora 9 with a self-compiled kernel 2.6.27-i686.

I run "yum-update" is to check if there are new updates for Fedora 9, and thus, hangs when

Cleanup   : openssh-server               ##################### [478/705]

If "yum update" cannot us SSH to update openssh-server, could it skip this update or set a job to update after next reboot or issuess warning to users, thanks.

Note You need to log in before you can comment on or make changes to this bug.