Bug 485064 - patch: fix getaddrinfo usage
patch: fix getaddrinfo usage
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-11 08:39 EST by Sami Farin
Modified: 2009-07-21 07:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-21 07:31:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix getaddrinfo usage (2.27 KB, patch)
2009-02-11 08:39 EST, Sami Farin
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Network Time Protocol 1129 None None None Never

  None (edit)
Description Sami Farin 2009-02-11 08:39:51 EST
Created attachment 331561 [details]
fix getaddrinfo usage

Description of problem:
in openntp() and init_io(), wrong error is reported because it is assumed errno holds the error value.
also, print correct error in getnetnum().

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Miroslav Lichvar 2009-02-11 09:18:26 EST
Forwarded to upstream:
https://support.ntp.org/bugs/show_bug.cgi?id=1129
Comment 2 Bug Zapper 2009-06-09 07:16:40 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Miroslav Lichvar 2009-07-21 07:31:27 EDT
The ntp_intres part of the patch was included in 4.2.4p7. The others seem to be less important, closing as UPSTREAM.

Note You need to log in before you can comment on or make changes to this bug.