Bug 485087 - Wrongly assembly path in x86_64 package
Wrongly assembly path in x86_64 package
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xsp (Show other bugs)
10
All Linux
low Severity urgent
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-11 10:16 EST by Luca Foppiano
Modified: 2009-03-25 18:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 18:24:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luca Foppiano 2009-02-11 10:16:38 EST
Description of problem:

xsp2 doesn't work, the problem is:

[root@sboing ~]# xsp2
Cannot open assembly '/usr/lib/mono/2.0/xsp2.exe': No such file or directory.

It's just an error in /usr/bin/xsp2 and /usr/bin/xsp for x86_64 package, the problem is simply assembly location:

[root@sboing bin]# cat /usr/bin/xsp2 
#!/bin/sh
exec /usr/bin/mono $MONO_OPTIONS "/usr/lib/mono/2.0/xsp2.exe" "$@"


[root@sboing bin]# cat /usr/bin/xsp
#!/bin/sh
exec /usr/bin/mono $MONO_OPTIONS "/usr/lib/mono/2.0/xsp2.exe" "$@"

To fix it simply change /usr/lib/ with /usr/lib64 (of course this solution is only valid for x86_64 packages)


Version-Release number of selected component (if applicable):
xsp-2.0-4.fc10.x86_64


Steps to Reproduce:
1. yum install xsp
2. xps --help or xsp2 --help
Comment 1 Paul F. Johnson 2009-03-25 18:24:35 EDT
Fixed in updates testing

Note You need to log in before you can comment on or make changes to this bug.