Bug 485158 - iwl3945 - rawhide regression START_ALIVE timeout
iwl3945 - rawhide regression START_ALIVE timeout
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iwl3945-firmware (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-11 17:49 EST by Nigel Jones
Modified: 2009-03-06 05:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-06 05:37:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Jones 2009-02-11 17:49:54 EST
Description of problem:

Rawhide -- upgraded from F10
NetworkManager used to manage connections
After suspend/resume iwl3945 driver does not work.

Observed network interface "wlan0" was not up:
wlan0     Link encap:Ethernet  HWaddr 00:13:02:29:D1:81  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
wlan0     IEEE 802.11abg  ESSID:""  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Tx-Power=15 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Trying to "up" resulted in

SIOCSIFFLAGS: Connection timed out

In dmesg observe errors like
iwl3945 0000:03:00.0: PCI INT A disabled
iwl3945 0000:03:00.0: restoring config space at offset 0x1 (was 0x100106, writing 0x100102)
iwl3945 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
iwl3945 0000:03:00.0: irq 31 for MSI/MSI-X
iwl3945: Wait for START_ALIVE timeout after 2000ms.
iwl3945 0000:03:00.0: PCI INT A disabled
iwl3945 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
iwl3945 0000:03:00.0: irq 31 for MSI/MSI-X
iwl3945: Wait for START_ALIVE timeout after 2000ms.
iwl3945 0000:03:00.0: PCI INT A disabled
iwl3945 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
iwl3945 0000:03:00.0: irq 31 for MSI/MSI-X
iwl3945: Wait for START_ALIVE timeout after 2000ms.
iwl3945 0000:03:00.0: PCI INT A disabled

I then used "rmmod iwl3945;modprobe iwl3945", and interface came up fine, networkmanager kicked in & back on-line.

Seems to happen regularly, did not happen with F10

Not sure if kernel or driver
Version-Release number of selected component (if applicable):
iwl4965-firmware-228.57.2.23-2.noarch
iwl3945-firmware-15.28.2.8-2.noarch
kernel-PAE-2.6.29-0.99.rc4.git1.fc11.i686
NetworkManager-0.7.0-2.git20090207.fc11.i386


How reproducible:
Has been failing since rawhide applied

Steps to Reproduce:
0. Boot up, connect to wifi (automaic) via networkmanager
1. Suspend
2. Resume
3. Wifi unavailable
  
Actual results:
No wifi

Expected results:
wifi

Additional info:
Comment 1 Nigel Jones 2009-02-16 18:46:01 EST
Now running kernel-PAE-2.6.29-0.119.rc5.fc11.i686 and not seeing this bug (nor in 118). Will monitor for few more days
Comment 2 Nigel Jones 2009-02-23 04:58:47 EST
no reoccurances. now up to 2.6.29-0.137.rc5.git4.fc11.i686.PAE

Note You need to log in before you can comment on or make changes to this bug.