Bug 485174 - No menu bars and No title bars are appeared.
No menu bars and No title bars are appeared.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-11 22:53 EST by Masao Takahashi
Modified: 2009-03-04 02:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 02:39:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Masao Takahashi 2009-02-11 22:53:15 EST
Description of problem:
After upgrade from 2.25.3 to 2.25.5,
No menu bars and No title bars in all windows are appeared.
But reverted to 2.25.3, 

Version-Release number of selected component (if applicable):
gnome-session-2.25.5 and gnome-session-2.25.90-1

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthias Clasen 2009-02-12 10:22:23 EST
Is metacity not starting, or is it crashing ?

What is the output of 

gconftool-2 --get /desktop/gnome/session/required_components/windowmanager 

?
Comment 2 Masao Takahashi 2009-02-12 18:14:28 EST
(In reply to comment #1)
> Is metacity not starting, or is it crashing ?
metacity is not started.
> 
> What is the output of 
> 
> gconftool-2 --get /desktop/gnome/session/required_components/windowmanager 
metacity
> 
> ?
Comment 3 Masao Takahashi 2009-02-19 01:11:04 EST
gnome-session-2.25.91-1.fc11 has same problems.
Metacity is not started.
Comment 4 Masao Takahashi 2009-02-27 00:41:33 EST
I tried to edit gconf schemas with gconf-editor as belows.
And I copy  gnome-wm.desktop to the directories as belows.

Then metacity is started successfully.
And a menu bar and a title bar with every window are appeared and works.

1. gnome-session schema change
   
    old : windowmanager=metacity
    new : windowmanager=gnome-wm

2. copy a gnome-wm.desktop file to 
   /usr/share/applications/
   /home/$USERNAME/.local/share/applications/
   /home/$USERNAME/.gnome2/panel2.d/default/launchers
   /usr/share/gdm/autostart/LoginWindow

I think that new gnome-session needs gnome-wm instead of metacity.
Don't you ?
Comment 5 Matthias Clasen 2009-02-27 18:55:28 EST
> I think that new gnome-session needs gnome-wm instead of metacity.
> Don't you ?

No.

There is obviously something amiss with your installation, since everybody else _is_ getting metacity. It would be interesting to know if your problem goes away in a fresh user account.
Comment 6 Masao Takahashi 2009-03-04 02:39:25 EST
After I applied latest rawhide updates, this problem is disappered.

gnome-session-2.25.91-4.fc11.i586
GConf2-2.25.2-2.fc11.i586
gdm-2.25.2-8.fc11.i586

I don't know why.

Note You need to log in before you can comment on or make changes to this bug.