Bug 485197 - Cannot get iso file's location and cdrom when using qemu to ssh node and creating a kvm
Cannot get iso file's location and cdrom when using qemu to ssh node and crea...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.4
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 05:00 EST by Jia Dong
Modified: 2016-04-26 10:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 11:04:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jia Dong 2009-02-12 05:00:14 EST
Description of problem:



Version-Release number of selected component (if applicable):
0.97-rc4

How reproducible:
every time

Steps to Reproduce:
1.# virt-manager
2.Click File-> Add connection
3.Select "QEMU" in "Hypervisor"
4.Select "Remote tunnel over SSH" in "Connection"
5.Input the host name of ovirt-node
6.Click "connect" button and input password
7.Click “Forward” to "Locating installation media"
  
Actual results:

If fill the right iso location of ovirt-node,it prompts "ISO Path not found".
Have inserted a CD on the ovirt-node,it can not find it,too.

Expected results:
It should find the file location and cdrom.

Additional info:
I create a kvm on ovirt-node and try to start it.
It prompts "Could not initialize SDL -exiting".I think this may be no graphics.So when trying to check kvm on ovirt-node,there is only the ssh way,right?
Comment 1 Alan Pevec 2009-02-12 05:16:41 EST
when running qemu-kvm direcly, please use -vnc option


The rest is virt-manager issue, which version/OS is it?
Please change component accordingly.

But I'm not sure if virt-manager is using libvirt's Storage API already?.
David Huff was also trying to use virt-manager with the remote RHEV-H.
David, do you have BZ for your issue?
Comment 2 Perry Myers 2009-02-12 10:52:21 EST
This issue should really be filed against RHEL not RHEV-H since for RHEV-H we don't support virt-manager with the Node.  I'm going to move this to be a RHEL5.4 bug.
Comment 3 Jia Dong 2009-02-13 00:09:57 EST
(In reply to comment #1) 
> 
> The rest is virt-manager issue, which version/OS is it?
> Please change component accordingly.

OS:Fedora10 i386

Virt-manager:virt-manager-0.6.0-5.fc10.i386
Comment 4 Cole Robinson 2009-02-13 11:04:32 EST
I don't think this is a bug. If you are inserting a CD on the remote machine, the only way virt-manager is going to know whether it exists or not is if the cdrom device is part of a libvirt storage pool.

Please see http://virt-manager.et.redhat.com/page/RemoteVMCreation for more details.

Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.