Bug 485212 - plan --add command may end up with irrelevant UDI information
plan --add command may end up with irrelevant UDI information
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
5.3
All Linux
low Severity low
: ---
: ---
Assigned To: Greg Nichols
Guangze Bai
:
Depends On: 488129
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 07:42 EST by Greg Nichols
Modified: 2015-02-08 16:36 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In v7 1.2, "v7 plan --add" command may end up with irrelevant UDI information in cpuscaling test. This issue has been fixed in v7 1.3, now cpuscaling test is no longer associated with a logical CPU device, only one cpuscaling instance will be executed during testing, thus no irrelevant UDI information any more.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-09 12:15:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Nichols 2009-02-12 07:42:53 EST
Description of problem:

The command to manually add tests may result in irrelevant UDI information being associated with the test.   For example, if a cpuscaling test is added using --device <cpunumber>.
Comment 1 Greg Nichols 2009-02-19 13:22:26 EST
The problem is that when --device is used, HTS tries to associate the test with a device discovered by HAL (or Kudzu on RHEL4).   Since there is no universal attribute for a "logical" device name, it tries to match the provided string against any attribute value.   If the string passed in via --device is one or two characters, as in this example, it could match any device.

The cpuscaling test does not use the association at all, only the literal value passed in by --device.   This situation is difficult to improve with out compromising the utility of the plan --add command as a work-around.

One possible heuristic would be to only attempt device matches if 3 or more characters were provided.  That would allow the addition of the storage command for "sda", or the network command for "eth2", but prevent the spurious association when "1" was passed in as the device for the cpuscaling test.

I complete and correct fix would be to encode knowledge in the tests about which attributes defined "logical" device name.   For the cpuscaling test, it would state None to indicate that it didn't require a device association.  The storage test could specify that it needed to match a substring of the block.device attribute under HAL, and the "device" property under Kudzu.

Alternatively, we could not fix this bug, as the resulting strings in the print command really are just a slightly-confusing cosmetic issue, in the context of a command that is only provided as a work-around for other RHEL or HTS bugs.
Comment 2 Rob Landry 2009-02-19 15:11:53 EST
Just an idea, since --add and subsequently --device means we're in manual try to do what the user tells us since auto detection didn't work or it's values are not desired mode, perhaps we could require both --udi and --device as input for all --add cases?  

This would require more of the user in these cases to include sometimes requiring a 'none' value where it's not needed/desired but it would also clean up the cosmetic issue and ensure that manual test plan definitions are fully defined even if incorrectly by the user at least establishing a full 'do as I say' manual mode?

...the point of the idea being to minimize the time spent coding on a cosmetic issue while still fixing the bug and at least partially improving the user experience?
Comment 6 Greg Nichols 2011-01-20 14:34:57 EST
Bug 488129 proposes a solution that could be extended to fix this bug as well, by removing code that attempts to associate a device with a test, and replacing it with a manual prompt in the test's "verify" phase.
Comment 13 Caspar Zhang 2011-05-01 02:45:17 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
In v7 1.2, "v7 plan --add" command may end up with irrelevant UDI information in cpuscaling test. This issue has been fixed in v7 1.3, now cpuscaling test is no longer associated with a logical CPU device, only one cpuscaling instance will be executed during testing.
Comment 14 Caspar Zhang 2011-05-01 02:46:04 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-In v7 1.2, "v7 plan --add" command may end up with irrelevant UDI information in cpuscaling test. This issue has been fixed in v7 1.3, now cpuscaling test is no longer associated with a logical CPU device, only one cpuscaling instance will be executed during testing.+In v7 1.2, "v7 plan --add" command may end up with irrelevant UDI information in cpuscaling test. This issue has been fixed in v7 1.3, now cpuscaling test is no longer associated with a logical CPU device, only one cpuscaling instance will be executed during testing, thus no irrelevant UDI information any more.
Comment 15 errata-xmlrpc 2011-05-09 12:15:15 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0497.html

Note You need to log in before you can comment on or make changes to this bug.