Bug 485217 - Error while adding iSCSI device
Error while adding iSCSI device
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iscsi-initiator-utils (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
anaconda_trace_hash:c521e7e1c711b23dc...
:
Depends On:
Blocks: 511269
  Show dependency treegraph
 
Reported: 2009-02-12 08:32 EST by James Laska
Modified: 2013-09-02 02:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 511269 (view as bug list)
Environment:
Last Closed: 2009-02-12 10:46:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (63.61 KB, text/plain)
2009-02-12 08:32 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2009-02-12 08:32:00 EST
This bug was filed automatically by anaconda.
Comment 1 James Laska 2009-02-12 08:32:04 EST
Created attachment 331689 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2009-02-12 09:15:59 EST
Posting traceback for quick review ...

anaconda 11.5.0.17 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iscsi.py", line 244, in addTarget
    authinfo=authinfo)
  File "/usr/lib/anaconda/iw/autopart_type.py", line 295, in addIscsiDrive
    self.intf)
  File "/usr/lib/anaconda/iw/autopart_type.py", line 361, in addDrive
    rc = self.addIscsiDrive()
TypeError: argument 3 must be libiscsi.chapAuthInfo, not None
Comment 3 Hans de Goede 2009-02-12 10:34:20 EST
This is not an anaconda issue, but an issue with the python bindings for libiscsi, changing component to iscsi-initiator-utils and assigning to myself.
Comment 4 Hans de Goede 2009-02-12 10:46:43 EST
Fixed in 6.2.0.870-4, closing.

mchristie, when you move libiscsi upstream please do not forget to add this patch (see Fedora cvs).
Comment 5 James Laska 2009-02-12 10:50:32 EST
FYI ... updates image to work around this issue available at http://people.atrpms.net/~hdegoede/updates485217.img
Comment 6 Hans de Goede 2009-02-12 11:12:51 EST
(In reply to comment #5)
> FYI ... updates image to work around this issue available at
> http://people.atrpms.net/~hdegoede/updates485217.img

FYI this is i386 only!

Note You need to log in before you can comment on or make changes to this bug.